summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2016-12-28 14:35:15 +0100
committerDavid Runge2016-12-28 14:35:15 +0100
commit304484aeb29bbd4a361e551f5425dac5dab720b8 (patch)
treed162af5c7b7f4e0652f73a4a1ad2eaf3f5cd6072
parent667544ec8f0ef4a882c2759ee69126712d1bbf93 (diff)
downloadaur-304484aeb29bbd4a361e551f5425dac5dab720b8.tar.gz
PKGBUILD: Adding ssr-qt4.patch to build ssr with qt4 exclusively.
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--ssr-qt4.patch11
3 files changed, 24 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 847a6890b7c3..6ab3f70f32e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Mon Apr 25 14:35:39 UTC 2016
+# Wed Dec 28 13:34:32 UTC 2016
pkgbase = ssr
pkgdesc = The SoundScape Renderer (SSR) is a tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques.
pkgver = 0.4.2
- pkgrel = 2
+ pkgrel = 3
url = http://spatialaudio.net/ssr/
arch = i686
arch = x86_64
@@ -21,7 +21,9 @@ pkgbase = ssr
conflicts = ssr
replaces = ssr
source = https://github.com/SoundScapeRenderer/ssr/releases/download/0.4.2/ssr-0.4.2.tar.gz
+ source = ssr-qt4.patch
md5sums = d49b746a6959a0d3771fde4de686a044
+ md5sums = 57f9c5f6432683ad8d231f56223a58ca
pkgname = ssr
diff --git a/PKGBUILD b/PKGBUILD
index 03336a5860f6..ebfe2f8a3bef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Runge <dave@sleepmap.de>
pkgname=ssr
pkgver=0.4.2
-pkgrel=2
+pkgrel=3
pkgdesc="The SoundScape Renderer (SSR) is a tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques."
arch=('i686' 'x86_64')
url="http://spatialaudio.net/ssr/"
@@ -11,9 +11,15 @@ provides=('ssr')
license=('GPL3')
depends=('jack' 'libsndfile' 'fftw' 'libxml2' 'ecasound' 'qt4>=4.2.2')
makedepends=('git' 'boost-libs>=1.35' 'help2man')
-source=("https://github.com/SoundScapeRenderer/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('d49b746a6959a0d3771fde4de686a044')
+source=("https://github.com/SoundScapeRenderer/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
+ "ssr-qt4.patch")
+md5sums=('d49b746a6959a0d3771fde4de686a044'
+ '57f9c5f6432683ad8d231f56223a58ca')
+prepare() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ patch -i "$srcdir/${pkgname}-qt4.patch"
+}
build() {
cd "$srcdir/${pkgname}-${pkgver}/"
diff --git a/ssr-qt4.patch b/ssr-qt4.patch
new file mode 100644
index 000000000000..ebd3aaaddc7d
--- /dev/null
+++ b/ssr-qt4.patch
@@ -0,0 +1,11 @@
+--- configure 2014-07-24 13:06:30.000000000 +0200
++++ configure.new 2016-12-28 14:09:35.995052402 +0100
+@@ -17678,7 +17678,7 @@
+ MOCFLAGS="$QT_CFLAGS"
+ if which moc 2>&1 >/dev/null; then :
+
+- QTMOC="moc"
++ QTMOC="moc-qt4"
+
+ else
+