summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-10-25 02:15:02 +0200
committerDavid Runge2017-10-25 02:15:02 +0200
commit48d8f7a92d2cab2d4c218c8c7b47f083a9d3664a (patch)
tree26048b4486d02471012ddb88a0d7bf84d84a7094
parent304484aeb29bbd4a361e551f5425dac5dab720b8 (diff)
downloadaur-48d8f7a92d2cab2d4c218c8c7b47f083a9d3664a.tar.gz
PKGBUILD: Updating pkgdesc to be non self-referential. Fixing conflicts and replaces. Moving boost-libs from makedepends to depends. Switching to sha512sums. Removing legacy tees from build().
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 19 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ab3f70f32e0..b162d1cfb509 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,28 @@
# Generated by mksrcinfo v8
-# Wed Dec 28 13:34:32 UTC 2016
+# Wed Oct 25 00:13:31 UTC 2017
pkgbase = ssr
- pkgdesc = The SoundScape Renderer (SSR) is a tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques.
+ pkgdesc = A tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques.
pkgver = 0.4.2
- pkgrel = 3
+ pkgrel = 4
url = http://spatialaudio.net/ssr/
arch = i686
arch = x86_64
license = GPL3
makedepends = git
- makedepends = boost-libs>=1.35
makedepends = help2man
depends = jack
depends = libsndfile
depends = fftw
depends = libxml2
depends = ecasound
- depends = qt4>=4.2.2
+ depends = qt4
+ depends = boost-libs
provides = ssr
- conflicts = ssr
- replaces = ssr
+ conflicts = ssr-git
source = https://github.com/SoundScapeRenderer/ssr/releases/download/0.4.2/ssr-0.4.2.tar.gz
source = ssr-qt4.patch
- md5sums = d49b746a6959a0d3771fde4de686a044
- md5sums = 57f9c5f6432683ad8d231f56223a58ca
+ sha512sums = 9e0364a499b5bd3526ff29575cbc2c0cf5b62d7915a0bd6c9df0c9cb54fa042c1052a2438dd8f2d903e61016ac8f0f6f0393aea01075574052b879f72b47d129
+ sha512sums = ac99cfc8fd939bfe41fa6ad9e2cfd4dd603c94a9d0d376389bd372f7082622dd229d709ce55bfb0fb3ae068b7d87cec9817b318efc7038b34dbe8eb70545204b
pkgname = ssr
diff --git a/PKGBUILD b/PKGBUILD
index ebfe2f8a3bef..f23b25077519 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,19 @@
# Maintainer: David Runge <dave@sleepmap.de>
pkgname=ssr
pkgver=0.4.2
-pkgrel=3
-pkgdesc="The SoundScape Renderer (SSR) is a tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques."
+pkgrel=4
+pkgdesc="A tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques."
arch=('i686' 'x86_64')
url="http://spatialaudio.net/ssr/"
-conflicts=('ssr')
-replaces=('ssr')
+conflicts=('ssr-git')
provides=('ssr')
license=('GPL3')
-depends=('jack' 'libsndfile' 'fftw' 'libxml2' 'ecasound' 'qt4>=4.2.2')
-makedepends=('git' 'boost-libs>=1.35' 'help2man')
+depends=('jack' 'libsndfile' 'fftw' 'libxml2' 'ecasound' 'qt4' 'boost-libs')
+makedepends=('git' 'help2man')
source=("https://github.com/SoundScapeRenderer/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"ssr-qt4.patch")
-md5sums=('d49b746a6959a0d3771fde4de686a044'
- '57f9c5f6432683ad8d231f56223a58ca')
+sha512sums=('9e0364a499b5bd3526ff29575cbc2c0cf5b62d7915a0bd6c9df0c9cb54fa042c1052a2438dd8f2d903e61016ac8f0f6f0393aea01075574052b879f72b47d129'
+ 'ac99cfc8fd939bfe41fa6ad9e2cfd4dd603c94a9d0d376389bd372f7082622dd229d709ce55bfb0fb3ae068b7d87cec9817b318efc7038b34dbe8eb70545204b')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}/"
@@ -22,14 +21,14 @@ prepare() {
}
build() {
- cd "$srcdir/${pkgname}-${pkgver}/"
+ cd "${pkgname}-${pkgver}/"
export QT_SELECT=4
- ./configure --prefix=/usr --disable-vrpn 2>&1 | tee configure.log
- make 2>&1 | tee make.log
+ ./configure --prefix=/usr --disable-vrpn
+ make
}
package() {
- cd "$srcdir/${pkgname}-${pkgver}/"
+ cd "${pkgname}-${pkgver}/"
make DESTDIR="$pkgdir" install
}