summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2017-10-31 10:46:02 +0100
committerDavid Runge2017-10-31 10:46:02 +0100
commit99bbe1e6be3b8bb569682202357905c954ea1205 (patch)
treeaf377371d3711f479960a2bc2c8784e927c3df49
parent48d8f7a92d2cab2d4c218c8c7b47f083a9d3664a (diff)
downloadaur-99bbe1e6be3b8bb569682202357905c954ea1205.tar.gz
PKGBUILD: Properly applying the qt4 patch and calling autoreconf again in prepare().
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD5
-rw-r--r--ssr-qt4.patch19
3 files changed, 17 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b162d1cfb509..7bedb26f4a88 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Oct 25 00:13:31 UTC 2017
+# Tue Oct 31 09:45:16 UTC 2017
pkgbase = ssr
pkgdesc = A tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques.
pkgver = 0.4.2
- pkgrel = 4
+ pkgrel = 5
url = http://spatialaudio.net/ssr/
arch = i686
arch = x86_64
@@ -22,7 +22,7 @@ pkgbase = ssr
source = https://github.com/SoundScapeRenderer/ssr/releases/download/0.4.2/ssr-0.4.2.tar.gz
source = ssr-qt4.patch
sha512sums = 9e0364a499b5bd3526ff29575cbc2c0cf5b62d7915a0bd6c9df0c9cb54fa042c1052a2438dd8f2d903e61016ac8f0f6f0393aea01075574052b879f72b47d129
- sha512sums = ac99cfc8fd939bfe41fa6ad9e2cfd4dd603c94a9d0d376389bd372f7082622dd229d709ce55bfb0fb3ae068b7d87cec9817b318efc7038b34dbe8eb70545204b
+ sha512sums = 030dd250e16e05872e7f97d893d81bfdd95ff8a90a8bc35ed1e69a644a92679602f17375e73529f260debfc5d3ae31e3b1d4976985c5e76bd9fd762a8af07551
pkgname = ssr
diff --git a/PKGBUILD b/PKGBUILD
index f23b25077519..d99f819606d7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: David Runge <dave@sleepmap.de>
pkgname=ssr
pkgver=0.4.2
-pkgrel=4
+pkgrel=5
pkgdesc="A tool for real-time spatial audio reproduction providing a variety of rendering algorithms, e.g. Wave Field Synthesis, Higher-Order Ambisonics and binaural techniques."
arch=('i686' 'x86_64')
url="http://spatialaudio.net/ssr/"
@@ -13,11 +13,12 @@ makedepends=('git' 'help2man')
source=("https://github.com/SoundScapeRenderer/${pkgname}/releases/download/${pkgver}/${pkgname}-${pkgver}.tar.gz"
"ssr-qt4.patch")
sha512sums=('9e0364a499b5bd3526ff29575cbc2c0cf5b62d7915a0bd6c9df0c9cb54fa042c1052a2438dd8f2d903e61016ac8f0f6f0393aea01075574052b879f72b47d129'
- 'ac99cfc8fd939bfe41fa6ad9e2cfd4dd603c94a9d0d376389bd372f7082622dd229d709ce55bfb0fb3ae068b7d87cec9817b318efc7038b34dbe8eb70545204b')
+ '030dd250e16e05872e7f97d893d81bfdd95ff8a90a8bc35ed1e69a644a92679602f17375e73529f260debfc5d3ae31e3b1d4976985c5e76bd9fd762a8af07551')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}/"
patch -i "$srcdir/${pkgname}-qt4.patch"
+ autoreconf -fi
}
build() {
diff --git a/ssr-qt4.patch b/ssr-qt4.patch
index ebd3aaaddc7d..2726f945092e 100644
--- a/ssr-qt4.patch
+++ b/ssr-qt4.patch
@@ -1,11 +1,14 @@
---- configure 2014-07-24 13:06:30.000000000 +0200
-+++ configure.new 2016-12-28 14:09:35.995052402 +0100
-@@ -17678,7 +17678,7 @@
+--- configure.ac 2017-10-31 10:35:05.089683111 +0100
++++ configure.ac.new 2017-10-31 10:37:50.698720873 +0100
+@@ -489,9 +489,9 @@
+ LIBS="$LIBS $QT_LIBS"
+ PKG_FLAGS="$PKG_FLAGS $QT_CFLAGS"
MOCFLAGS="$QT_CFLAGS"
- if which moc 2>&1 >/dev/null; then :
-
+- AS_IF([which moc 2>&1 >/dev/null],
++ AS_IF([which moc-qt4 2>&1 >/dev/null],
+ [
- QTMOC="moc"
+ QTMOC="moc-qt4"
-
- else
-
+ ],
+ [
+ QTMOC=`$PKG_CONFIG --variable=moc_location QtCore`