summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam J. Bowman2016-01-25 18:06:29 -0500
committerWilliam J. Bowman2016-01-25 18:06:29 -0500
commit73ef612e6a292be00c5216e35a30339a9dfe60bf (patch)
tree7ae9c854f3b5b5b749f9399c4d95e7708d92ac28
parentc03a64cf2947df047516bd9ce95b759a5e1dbbe0 (diff)
downloadaur-73ef612e6a292be00c5216e35a30339a9dfe60bf.tar.gz
Update to 1.6-1
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD20
2 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 683de332e6a7..235d4cc9402c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jan 25 23:06:20 UTC 2016
pkgbase = ssreflect
pkgdesc = A set of extensions to the scripting language of Coq.
- pkgver = 1.5
- pkgrel = 2
- url = http://ssr.msr-inria.inria.fr/
+ pkgver = 1.6
+ pkgrel = 1
+ url = https://math-comp.github.io/math-comp/
arch = i686
arch = x86_64
license = GPL
makedepends = camlp5-transitional>=6.12
- depends = coq<8.5
- source = http://ssr.msr-inria.inria.fr/FTP/ssreflect-1.5.tar.gz
- sha256sums = bad978693d1bfd0a89586a34678bcc244e3b7efba6431e0f83d8e1ae8f82a142
- sha512sums = 4d2ece36609ecc38796568e13d3fe093eefa1bd0bd0c062788ef10c639bccba37bc40023098ea609f5877a1afcbc08c346e1a69640203cd95a9e75709816642f
+ depends = coq=8.5
+ source = mathcomp-1.6.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-1.6
+ sha256sums = 19c5b5b872f50f8b055b86ea3d42692549813b0ebf1ebc6cfa1f05c8892a1bea
+ sha512sums = b98e82fc39f44c2c885b739a1693c403278912703910efb54bca27096581074b5e11742a41e48b4923b515b549c3290a26b1d43b8dae0c2b56f85d40f56f5a4b
pkgname = ssreflect
diff --git a/PKGBUILD b/PKGBUILD
index 266335585043..d33002319af4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,20 +7,20 @@
# - when building ssreflect modify the download location, as mentioned by daoo, and if you have coq 8.4pl4-1 you will have to remove the coq>=8.4 dependency since makepkg gets confused.
pkgname=ssreflect
-pkgver=1.5
-pkgrel=2
+pkgver=1.6
+pkgrel=1
pkgdesc="A set of extensions to the scripting language of Coq."
-url="http://ssr.msr-inria.inria.fr/"
+url="https://math-comp.github.io/math-comp/"
arch=('i686' 'x86_64')
license=('GPL')
-depends=('coq<8.5') # 'coq>=8.4'
+depends=('coq=8.5') # Also works with 8.4pl6 but don't quite know how to say that
makedepends=('camlp5-transitional>=6.12')
-source=(http://ssr.msr-inria.inria.fr/FTP/ssreflect-1.5.tar.gz)
-sha256sums=('bad978693d1bfd0a89586a34678bcc244e3b7efba6431e0f83d8e1ae8f82a142')
-sha512sums=('4d2ece36609ecc38796568e13d3fe093eefa1bd0bd0c062788ef10c639bccba37bc40023098ea609f5877a1afcbc08c346e1a69640203cd95a9e75709816642f')
+source=(mathcomp-$pkgver.tar.gz::https://github.com/math-comp/math-comp/tarball/mathcomp-$pkgver)
+sha256sums=('19c5b5b872f50f8b055b86ea3d42692549813b0ebf1ebc6cfa1f05c8892a1bea')
+sha512sums=('b98e82fc39f44c2c885b739a1693c403278912703910efb54bca27096581074b5e11742a41e48b4923b515b549c3290a26b1d43b8dae0c2b56f85d40f56f5a4b')
build() {
- cd $srcdir/$pkgname-$pkgver
+ cd $srcdir/math-comp-math-comp-52a8679/mathcomp/$pkgname
# SSReflect requires *a lot* of memory to build. It can be a good
# idea add -j1 to the following command to force a sequential build.
@@ -28,7 +28,7 @@ build() {
}
package(){
- cd $srcdir/$pkgname-$pkgver
- make DESTDIR=$pkgdir 'COQLIB:=$(DESTDIR)/$(shell coqtop -where)/' install
+ cd $srcdir/math-comp-math-comp-52a8679/mathcomp/$pkgname
+ make DSTROOT=$pkgdir 'COQLIB:=$(DESTDIR)/$(shell coqtop -where)/' install
}