summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXuanrui Qi2022-03-18 00:05:09 +0900
committerXuanrui Qi2022-03-18 00:05:09 +0900
commite77fb10d5976ae1274f7a27f7b5dcd76927139e0 (patch)
treef5a06676b1f5aa8f73a02f89e19f7894c2a8068a
parent386b5d693afbe684de40e31c1f3ef9015147b765 (diff)
downloadaur-e77fb10d5976ae1274f7a27f7b5dcd76927139e0.tar.gz
Fix a small bug in install file
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD9
-rw-r--r--license.patch13
3 files changed, 23 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f062943f9cf5..c41752b4f0ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ssrmint-git
pkgdesc = Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect
pkgver = r13.fa1f7ab
- pkgrel = 3
+ pkgrel = 5
url = https://github.com/affeldt-aist/ssrmint
arch = any
license = BSD
@@ -10,7 +10,8 @@ pkgbase = ssrmint-git
depends = python
depends = python-pygments
source = ssrmint-git::git+https://github.com/affeldt-aist/ssrmint
- md5sums = SKIP
+ source = license.patch
+ sha256sums = SKIP
+ sha256sums = 6fa40b2b50c0cd2e513b2b9438a6d41e466a6012e7ac6d97f5ec578d44dfef5c
pkgname = ssrmint-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 3ac1382b7a50..f0adbf43efa9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Xuanrui Qi <me@xuanruiqi.com>
pkgname=ssrmint-git
pkgver=r13.fa1f7ab
-pkgrel=3
+pkgrel=5
pkgdesc="Ad-hoc pygments style and lexer for LaTeX pretty-printing of SSReflect"
arch=('any')
url="https://github.com/affeldt-aist/ssrmint"
@@ -10,8 +10,10 @@ depends=('python' 'python-pygments')
makedepends=('git' 'python-setuptools')
optdepends=()
conflicts=()
-source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/affeldt-aist/ssrmint"
+ "license.patch")
+sha256sums=('SKIP'
+ '6fa40b2b50c0cd2e513b2b9438a6d41e466a6012e7ac6d97f5ec578d44dfef5c')
pkgver() {
cd "$pkgname"
@@ -20,6 +22,7 @@ pkgver() {
build() {
cd "$srcdir/$pkgname"
+ patch -p1 < ../license.patch
python setup.py build
}
diff --git a/license.patch b/license.patch
new file mode 100644
index 000000000000..42abce87a675
--- /dev/null
+++ b/license.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 032fdcc..8973cfc 100644
+--- a/setup.py
++++ b/setup.py
+@@ -8,7 +8,7 @@ setup(
+ author = "Reynald Affeldt",
+ install_requires = ['pygments'],
+ packages = ['ssrmint'],
++ license = 'BSD',
+- license = ['BSD'],
+ entry_points = {
+ 'pygments.styles': ['ssr = ssrmint:SSRStyle'],
+ 'pygments.lexers': ['CoqLexer = ssrmint:SSRLexer'],