summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2019-06-19 18:40:53 +0200
committerJose Riha2019-06-19 18:40:53 +0200
commit8ed95e42a395b9ec70648baf5925129299ab9f32 (patch)
tree5bb8f07e517c2f0d71c366aa7a474d267215749f
parent91f9e26642d264d80cb3bd1710caf4aaff9542a8 (diff)
downloadaur-8ed95e42a395b9ec70648baf5925129299ab9f32.tar.gz
Fix build (thanks @maxdevaine)
-rw-r--r--.SRCINFO6
-rw-r--r--Makefile.patch11
-rw-r--r--PKGBUILD9
3 files changed, 20 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 785aa72fa8a0..80dcc827f9f1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,7 @@
-# Generated by mksrcinfo v8
-# Sun Jun 11 06:51:26 UTC 2017
pkgbase = ssvnc
pkgdesc = SSL/SSH VNC viewer
pkgver = 1.0.29
- pkgrel = 7
+ pkgrel = 8
url = http://www.karlrunge.com/x11vnc/ssvnc.html
arch = i686
arch = x86_64
@@ -25,8 +23,10 @@ pkgbase = ssvnc
optdepends = stunnel
source = http://downloads.sf.net/sourceforge/ssvnc/ssvnc-1.0.29.src.tar.gz
source = openssl1.1.patch
+ source = Makefile.patch
md5sums = 52201aeb0417c2a0fe83639e52da6ae5
md5sums = 6a119a5748a231f63c96044a2761845f
+ md5sums = 7d35673003f4f25a046c48f803e76e65
pkgname = ssvnc
diff --git a/Makefile.patch b/Makefile.patch
new file mode 100644
index 000000000000..dea3eca23b97
--- /dev/null
+++ b/Makefile.patch
@@ -0,0 +1,11 @@
+diff -aur ultraftp.orig/Makefile ultraftp/Makefile
+--- ultraftp.orig/Makefile 2019-06-19 18:37:41.913323155 +0200
++++ ultraftp/Makefile 2019-06-19 18:37:47.759989787 +0200
+@@ -3,7 +3,6 @@
+ SOURCES = $(shell echo *.java)
+ CLASSES = $(SOURCES:%.java=%.class)
+ ARCHIVE = ultraftp.jar
+-JC_ARGS = -target 1.4 -source 1.4
+
+ all: $(CLASSES) $(ARCHIVE)
+
diff --git a/PKGBUILD b/PKGBUILD
index bc3ad146b926..48eb98e1d517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=ssvnc
pkgver=1.0.29
-pkgrel=7
+pkgrel=8
pkgdesc="SSL/SSH VNC viewer"
arch=('i686' 'x86_64')
url="http://www.karlrunge.com/x11vnc/ssvnc.html"
@@ -13,13 +13,16 @@ depends=('libjpeg>=7' 'libxaw' 'openssl' 'java-runtime' 'tk' 'tcl' 'stunnel')
makedepends=('imake' 'java-environment')
optdepends=('perl' 'xterm' 'smbclient' 'avahi' 'stunnel')
source=(http://downloads.sf.net/sourceforge/$pkgname/$pkgname-$pkgver.src.tar.gz
- openssl1.1.patch)
+ openssl1.1.patch
+ Makefile.patch)
md5sums=('52201aeb0417c2a0fe83639e52da6ae5'
- '6a119a5748a231f63c96044a2761845f')
+ '6a119a5748a231f63c96044a2761845f'
+ '7d35673003f4f25a046c48f803e76e65')
prepare() {
cd "$srcdir/$pkgname-$pkgver"
patch -p1 < "$srcdir/openssl1.1.patch"
+ patch -p0 < "../../Makefile.patch"
}
build() {