summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMorten Linderud2017-11-20 16:31:33 +0100
committerMorten Linderud2017-11-20 16:31:33 +0100
commitca4780522a7fb64763aa66bfbef45b9853a52a75 (patch)
tree0a9d8fd1626f06712a9645abf0320c70fba7d78a
parent29d59144813997622f75c725864d36c5870dae5f (diff)
downloadaur-ca4780522a7fb64763aa66bfbef45b9853a52a75.tar.gz
upgpkg: st 0.7-1
upstream release Added old st from community Signed-off-by: Morten Linderud <morten@linderud.pw>
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
-rw-r--r--config.h82
3 files changed, 95 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ef66d17eb35..c55163084647 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
+# Generated by mksrcinfo v8
+# Mon Nov 20 15:31:38 UTC 2017
pkgbase = st
pkgdesc = A simple virtual terminal emulator for X.
- pkgver = 0.6
- pkgrel = 2
+ pkgver = 0.7
+ pkgrel = 1
url = http://st.suckless.org
arch = i686
arch = x86_64
license = MIT
makedepends = ncurses
depends = libxft
- source = http://dl.suckless.org/st/st-0.6.tar.gz
+ depends = libxext
+ depends = xorg-fonts-misc
+ source = http://dl.suckless.org/st/st-0.7.tar.gz
source = config.h
- md5sums = 1a926f450b4eacb7e2f5ac5b8ffea7c8
- md5sums = 90ce5919be96de000bd9d9429b173490
+ md5sums = 29b2a599cf1511c8062ed8f025c84c63
+ md5sums = 9cb789e3912df36f296a219e1b9da850
pkgname = st
diff --git a/PKGBUILD b/PKGBUILD
index 0c9e42cc9bd2..258dea3b62a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,34 @@
# Maintainer: Christoph Vigano <mail@cvigano.de>
pkgname=st
-pkgver=0.6
-pkgrel=2
+pkgver=0.7
+pkgrel=1
pkgdesc='A simple virtual terminal emulator for X.'
arch=('i686' 'x86_64')
license=('MIT')
-depends=('libxft')
+depends=('libxft' 'libxext' 'xorg-fonts-misc')
makedepends=('ncurses')
url="http://st.suckless.org"
source=(http://dl.suckless.org/st/$pkgname-$pkgver.tar.gz
config.h)
+md5sums=('29b2a599cf1511c8062ed8f025c84c63'
+ '9cb789e3912df36f296a219e1b9da850')
-build() {
+prepare() {
cd $srcdir/$pkgname-$pkgver
+ # skip terminfo which conflicts with nsurses
+ sed -i '/\@tic /d' Makefile
cp $srcdir/config.h config.h
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
}
package() {
cd $srcdir/$pkgname-$pkgver
- sed -i '/\@tic /d' Makefile
make PREFIX=/usr DESTDIR="$pkgdir" TERMINFO="$pkgdir/usr/share/terminfo" install
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
- install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
}
-md5sums=('1a926f450b4eacb7e2f5ac5b8ffea7c8'
- '90ce5919be96de000bd9d9429b173490')
diff --git a/config.h b/config.h
index 64e75b86dea6..046aef730bdc 100644
--- a/config.h
+++ b/config.h
@@ -5,11 +5,20 @@
*
* font: see http://freedesktop.org/software/fontconfig/fontconfig-user.html
*/
-static char font[] = "Liberation Mono:pixelsize=12:antialias=false:autohint=false";
+static char font[] = "Fixed:pixelsize=18:antialias=false:autohint=false";
static int borderpx = 2;
+
+/*
+ * What program is execed by st depends of these precedence rules:
+ * 1: program passed with -e
+ * 2: utmp option
+ * 3: SHELL environment variable
+ * 4: value of shell in /etc/passwd
+ * 5: value of shell in config.h
+ */
static char shell[] = "/bin/sh";
static char *utmp = NULL;
-static char stty_args[] = "stty raw -echo -iexten echonl";
+static char stty_args[] = "stty raw pass8 nl -echo -iexten -cstopb 38400";
/* identification sequence returned in DA and DECID */
static char vtiden[] = "\033[?6c";
@@ -30,7 +39,7 @@ static unsigned int doubleclicktimeout = 300;
static unsigned int tripleclicktimeout = 600;
/* alt screens */
-static bool allowaltscreen = true;
+static int allowaltscreen = 1;
/* frames per second st should at maximum draw to the screen */
static unsigned int xfps = 120;
@@ -53,12 +62,26 @@ static unsigned int cursorthickness = 2;
*/
static int bellvolume = 0;
-/* TERM value */
+/* default TERM value */
static char termname[] = "st-256color";
+/*
+ * spaces per tab
+ *
+ * When you are changing this value, don't forget to adapt the »it« value in
+ * the st.info and appropriately install the st.info in the environment where
+ * you use this st version.
+ *
+ * it#$tabspaces,
+ *
+ * Secondly make sure your kernel is not expanding tabs. When running `stty
+ * -a` »tab0« should appear. You can tell the terminal to not expand tabs by
+ * running following command:
+ *
+ * stty tabs
+ */
static unsigned int tabspaces = 8;
-
/* Terminal colors (16 first used in escape sequence) */
static const char *colorname[] = {
/* 8 normal colors */
@@ -85,16 +108,34 @@ static const char *colorname[] = {
/* more colors can be added after 255 to use with DefaultXX */
"#cccccc",
+ "#555555",
};
/*
* Default colors (colorname index)
- * foreground, background, cursor
+ * foreground, background, cursor, reverse cursor
*/
static unsigned int defaultfg = 7;
static unsigned int defaultbg = 0;
static unsigned int defaultcs = 256;
+static unsigned int defaultrcs = 257;
+
+/*
+ * Default shape of cursor
+ * 2: Block ("█")
+ * 4: Underline ("_")
+ * 6: Bar ("|")
+ * 7: Snowman ("☃")
+ */
+static unsigned int cursorshape = 2;
+
+/*
+ * Default colour and shape of the mouse cursor
+ */
+static unsigned int mouseshape = XC_xterm;
+static unsigned int mousefg = 7;
+static unsigned int mousebg = 0;
/*
* Colors used, when the specific fg == defaultfg. So in reverse mode this
@@ -104,9 +145,11 @@ static unsigned int defaultcs = 256;
static unsigned int defaultitalic = 11;
static unsigned int defaultunderline = 7;
-/* Internal mouse shortcuts. */
-/* Beware that overloading Button1 will disable the selection. */
-static Mousekey mshortcuts[] = {
+/*
+ * Internal mouse shortcuts.
+ * Beware that overloading Button1 will disable the selection.
+ */
+static MouseShortcut mshortcuts[] = {
/* button mask string */
{ Button4, XK_ANY_MOD, "\031" },
{ Button5, XK_ANY_MOD, "\005" },
@@ -117,6 +160,7 @@ static Mousekey mshortcuts[] = {
static Shortcut shortcuts[] = {
/* mask keysym function argument */
+ { XK_ANY_MOD, XK_Break, sendbreak, {.i = 0} },
{ ControlMask, XK_Print, toggleprinter, {.i = 0} },
{ ShiftMask, XK_Print, printscreen, {.i = 0} },
{ XK_ANY_MOD, XK_Print, printsel, {.i = 0} },
@@ -167,11 +211,17 @@ static KeySym mappedkeys[] = { -1 };
*/
static uint ignoremod = Mod2Mask|XK_SWITCH_MOD;
-/* Override mouse-select while mask is active (when MODE_MOUSE is set).
+/*
+ * Override mouse-select while mask is active (when MODE_MOUSE is set).
* Note that if you want to use ShiftMask with selmasks, set this to an other
- * modifier, set to 0 to not use it. */
+ * modifier, set to 0 to not use it.
+ */
static uint forceselmod = ShiftMask;
+/*
+ * This is the huge key array which defines all compatibility to the Linux
+ * world. Please decide about changes wisely.
+ */
static Key key[] = {
/* keysym mask string appkey appcursor crlf */
{ XK_KP_Home, ShiftMask, "\033[2J", 0, -1, 0},
@@ -268,6 +318,7 @@ static Key key[] = {
{ XK_Delete, XK_ANY_MOD, "\033[P", -1, 0, 0},
{ XK_Delete, XK_ANY_MOD, "\033[3~", +1, 0, 0},
{ XK_BackSpace, XK_NO_MOD, "\177", 0, 0, 0},
+ { XK_BackSpace, Mod1Mask, "\033\177", 0, 0, 0},
{ XK_Home, ShiftMask, "\033[2J", 0, -1, 0},
{ XK_Home, ShiftMask, "\033[1;2H", 0, +1, 0},
{ XK_Home, XK_ANY_MOD, "\033[H", 0, -1, 0},
@@ -382,3 +433,12 @@ static uint selmasks[] = {
[SEL_RECTANGULAR] = Mod1Mask,
};
+/*
+ * Printable characters in ASCII, used to estimate the advance width
+ * of single wide characters.
+ */
+static char ascii_printable[] =
+ " !\"#$%&'()*+,-./0123456789:;<=>?"
+ "@ABCDEFGHIJKLMNOPQRSTUVWXYZ[\\]^_"
+ "`abcdefghijklmnopqrstuvwxyz{|}~";
+