summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2016-09-03 13:34:17 +0200
committermar77i2016-09-03 13:34:17 +0200
commit278ae33272f0cafa397c5da57a29eaf4aa7f609a (patch)
tree603b15496322dcdd1f95fea1a5c7b44bb69053b3
parentdc05f486ca8fd0bf3ef85604125ada81f28ae9d5 (diff)
downloadaur-278ae33272f0cafa397c5da57a29eaf4aa7f609a.tar.gz
use -lXrendr, zipman, comment the source array and simplify the source loop, thanks prash
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6221c6bdeeab..32caae74c69e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,14 +4,16 @@
pkgname=st-git
_pkgname=st
-pkgver=20151011.f56c58a
+pkgver=20160309.3996461
pkgrel=1
pkgdesc='Simple virtual terminal emulator for X'
url='http://git.suckless.org/st/'
arch=('i686' 'x86_64')
license=('MIT')
+options=('zipman')
depends=('libxft')
makedepends=('ncurses' 'libxext' 'git')
+# include config.h and any patches you want to have applied here
source=('git://git.suckless.org/st')
sha1sums=('SKIP')
@@ -36,6 +38,7 @@ prepare() {
-e 's/CFLAGS =/CFLAGS +=/g' \
-e 's/LDFLAGS =/LDFLAGS +=/g' \
-e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
+ -e 's/\(-lXft\)/\1 -lXrender/' \
-i config.mk
sed '/@tic/d' -i Makefile
for file in "${source[@]}"; do
@@ -43,10 +46,9 @@ prepare() {
# add config.h if present in source array
# Note: this supersedes the above sed to config.def.h
cp "$srcdir/$file" .
- continue
- elif [[ "$file" == *.diff ]]; then
+ elif [[ "$file" == *.diff || "$file" == *.patch ]]; then
# add all patches present in source array
- patch -Np1 <"$srcdir/$file"
+ patch -Np1 <"$srcdir/$(basename ${file})"
fi
done
}