summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormar77i2015-06-25 10:50:30 +0200
committermar77i2015-06-25 10:50:30 +0200
commitc5b97b9a4779d9307ebf9a21ded89fce9be19444 (patch)
tree26455af54e31ca0ae90d11db7ac33117782fedaf
parent0df21d831f3d16cf15fcb07b55c962e88fc85143 (diff)
downloadaur-c5b97b9a4779d9307ebf9a21ded89fce9be19444.tar.gz
add config.h if present in source array
-rw-r--r--PKGBUILD3
1 files changed, 3 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 92713c4d2e4e..e1995a4caa0d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -41,6 +41,9 @@ prepare() {
sed '/@tic/d' -i Makefile
for file in "${source[@]}"; do
if [[ "$file" != *.diff ]]; then
+ # add config.h if present in source array
+ # Note: this supersedes the above sed to config.def.h
+ [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" .
continue
fi
# add all patches present in source array