summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Taylor2020-11-13 22:18:23 -0600
committerDerek Taylor2020-11-13 22:18:23 -0600
commit814273524dac78e155a74b4df0637da9c74619c8 (patch)
tree899790db3c164fcf309aff0f41706fcb0cbc6b3d
parent30cc3b0dbd3ce8a02842b8930e5efa208e793416 (diff)
downloadaur-814273524dac78e155a74b4df0637da9c74619c8.tar.gz
Pushing updated build of st
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 154685883bb1..f14a3a85c68c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = st-distrotube-git
pkgdesc = A heavily-patched and customized build of st (the Suckless simple terminal) from DistroTube.
- pkgver = 0.8.2
+ pkgver = 0.8.4
pkgrel = 1
url = https://gitlab.com/dwt1/st-distrotube.git
arch = x86_64
@@ -9,6 +9,7 @@ pkgbase = st-distrotube-git
makedepends = git
depends = ttf-hack
depends = ttf-joypixels
+ depends = nerd-fonts-source-code-pro
provides = st
conflicts = st
source = git+https://gitlab.com/dwt1/st-distrotube.git
diff --git a/PKGBUILD b/PKGBUILD
index 958eb81704dd..703d643506d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Derek Taylor (DistroTube) <derek@distrotube.com>
pkgname=st-distrotube-git
-pkgver=0.8.2
+pkgver=0.8.4
pkgrel=1
pkgdesc="A heavily-patched and customized build of st (the Suckless simple terminal) from DistroTube."
arch=(x86_64 i686)
url="https://gitlab.com/dwt1/st-distrotube.git"
license=('MIT')
groups=()
-depends=(ttf-hack ttf-joypixels)
+depends=(ttf-hack ttf-joypixels nerd-fonts-source-code-pro)
makedepends=(git)
checkdepends=()
optdepends=()
@@ -23,7 +23,7 @@ validpgpkeys=()
pkgver() {
cd "${_pkgname}"
- printf "0.8.2.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf "0.8.4.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
@@ -37,6 +37,6 @@ package() {
cp -rf * ${pkgdir}/opt/${pkgname}
make PREFIX=/usr DESTDIR="${pkgdir}" install
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+ install -Dm644 README.org "${pkgdir}/usr/share/doc/${pkgname}/README.org"
}