aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParide Legovini2019-01-10 13:36:09 +0100
committerHiltjo Posthuma2019-01-10 18:13:13 +0100
commit6d2c7fba9f1b79918e4867f41a1b5eb48b957ed0 (patch)
tree3a0be1e83470f8704222f8f91221c1722c092bf0
parentdeaa517c4ae9a94aed2c076576de9b115740b435 (diff)
downloadaur-6d2c7fba9f1b79918e4867f41a1b5eb48b957ed0.tar.gz
Let the user specify CPPFLAGS
This complements the work done in d4928ed, allowing the user to specify the preprocessor flags with the CPPFLAGS environment variable. This is useful for example to specify preprocessor macros with -D. CFLAGS could be used instead, but CPPFLAGS is more correct and is expected to be honored in some cases. For example, the helper scripts to build Debian packages make use of CPPFLAGS, but the variable is currently being ignored unless manually appended to CFLAGS.
-rw-r--r--config.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/config.mk b/config.mk
index 64a1da92c7b5..5059632c0da6 100644
--- a/config.mk
+++ b/config.mk
@@ -21,8 +21,8 @@ LIBS = -L$(X11LIB) -lm -lrt -lX11 -lutil -lXft \
`$(PKG_CONFIG) --libs freetype2`
# flags
-CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_XOPEN_SOURCE=600
-STCFLAGS = $(INCS) $(CPPFLAGS) $(CFLAGS)
+STCPPFLAGS = -DVERSION=\"$(VERSION)\" -D_XOPEN_SOURCE=600
+STCFLAGS = $(INCS) $(STCPPFLAGS) $(CPPFLAGS) $(CFLAGS)
STLDFLAGS = $(LIBS) $(LDFLAGS)
# OpenBSD: