aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorParide Legovini2019-01-04 09:48:37 +0100
committerHiltjo Posthuma2019-01-04 16:00:54 +0100
commitdeaa517c4ae9a94aed2c076576de9b115740b435 (patch)
tree25cfa4898ee6b1a9f4f26af43237caaf90ef1b41
parent6354c378229eb6df913d3fb52842bac2f3b6f60c (diff)
downloadaur-deaa517c4ae9a94aed2c076576de9b115740b435.tar.gz
Set the path of pkg-config in a variable instead of hardcoding it
In this way the path of pkg-config can be overridden from the command line. This is useful for example when cross-compiling.
-rw-r--r--config.mk10
1 files changed, 6 insertions, 4 deletions
diff --git a/config.mk b/config.mk
index e676105ba783..64a1da92c7b5 100644
--- a/config.mk
+++ b/config.mk
@@ -10,13 +10,15 @@ MANPREFIX = $(PREFIX)/share/man
X11INC = /usr/X11R6/include
X11LIB = /usr/X11R6/lib
+PKG_CONFIG = pkg-config
+
# includes and libs
INCS = -I$(X11INC) \
- `pkg-config --cflags fontconfig` \
- `pkg-config --cflags freetype2`
+ `$(PKG_CONFIG) --cflags fontconfig` \
+ `$(PKG_CONFIG) --cflags freetype2`
LIBS = -L$(X11LIB) -lm -lrt -lX11 -lutil -lXft \
- `pkg-config --libs fontconfig` \
- `pkg-config --libs freetype2`
+ `$(PKG_CONFIG) --libs fontconfig` \
+ `$(PKG_CONFIG) --libs freetype2`
# flags
CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_XOPEN_SOURCE=600