summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjacob2020-05-23 13:41:47 -0400
committerjacob2020-05-23 13:41:47 -0400
commitdff0c8a81dfb02d7c55228abac93b1817aa16ca9 (patch)
tree8f2f68a9796e349f51524e68623e1aaf6f2a0225
downloadaur-dff0c8a81dfb02d7c55228abac93b1817aa16ca9.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34c272e04d32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = st-jacob-git
+ pkgdesc = This Jacob McDonnell's build of st see the repo for more details
+ pkgver = 0.8.3.r1.1ff86da
+ pkgrel = 1
+ url = https://gitlab.com/Jacob_McDonnell/st.git
+ arch = x86_64
+ arch = i686
+ license = MIT/X Consortium License
+ makedepends = git
+ makedepends = make
+ optdepends = dmenu
+ optdepends = xurls
+ optdepends = xclip
+ optdepends = python-pywal
+ provides = st
+ conflicts = st
+ source = git+https://gitlab.com/Jacob_McDonnell/st.git
+ md5sums = SKIP
+
+pkgname = st-jacob-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca0fbdbab01c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Your Name <youremail@domain.com>
+pkgname=st-jacob-git
+pkgver=0.8.3.r1.1ff86da
+pkgrel=1
+pkgdesc="This Jacob McDonnell's build of st see the repo for more details"
+arch=(x86_64 i686)
+url="https://gitlab.com/Jacob_McDonnell/st.git"
+license=('MIT/X Consortium License')
+depends=()
+makedepends=(git make)
+optdepends=(dmenu xurls xclip python-pywal)
+provides=(st)
+conflicts=(st)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver(){
+ cd st
+ printf "0.8.3.r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd st
+ mkdir -p ${pkgdir}/opt/${pkgname}
+ cp -rf * ${pkgdir}/opt/${pkgname}
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}