summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonosans2020-12-26 14:57:34 +0300
committermonosans2020-12-26 14:57:34 +0300
commit1863eaf915939fee690b5b7cf60609c0933dc0c8 (patch)
tree017a56173271ea4612d3b4213df70e8ad69d702e
downloadaur-1863eaf915939fee690b5b7cf60609c0933dc0c8.tar.gz
Initial push
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD36
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cc52c998741c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = st-monosans-git
+ pkgdesc = Simple (suckless) terminal with scrollback, ligatures and One Dark color scheme
+ pkgver = 0.8.4.1138.8f63d8c
+ pkgrel = 1
+ url = https://github.com/monosans/st
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = libxext
+ makedepends = ncurses
+ depends = libxft
+ depends = harfbuzz
+ depends = ttf-jetbrains-mono
+ provides = st
+ conflicts = st
+ source = git://github.com/monosans/st
+ sha256sums = SKIP
+
+pkgname = st-monosans-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88cbfacf5a67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: monosans <hsyqixco at protonmail dot com>
+
+pkgname=st-monosans-git
+pkgver=0.8.4.1138.8f63d8c
+pkgrel=1
+pkgdesc='Simple (suckless) terminal with scrollback, ligatures and One Dark color scheme'
+url='https://github.com/monosans/st'
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('libxft' 'harfbuzz' 'ttf-jetbrains-mono')
+makedepends=('git' 'libxext' 'ncurses')
+source=('git://github.com/monosans/st')
+sha256sums=('SKIP')
+provides=('st')
+conflicts=('st')
+
+pkgver() {
+ cd st
+ _pkgver=$(awk '/VERSION/ {print $3}' config.mk|head -1)
+ echo "${_pkgver}.$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd st
+ sed -i '/tic /d' Makefile
+}
+
+build() {
+ cd st
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd st
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}