summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormonosans2021-01-04 19:12:40 +0300
committermonosans2021-01-04 19:12:40 +0300
commit1d9fccc2311a4e17ab76ef2535489cf05ebfcb54 (patch)
tree69f23007c0824776b793596de26cb248b9df8283
parent2360f6b6f7931a400f9fcd23f2860c5a8e234f3f (diff)
downloadaur-1d9fccc2311a4e17ab76ef2535489cf05ebfcb54.tar.gz
Add config.mk
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD6
-rw-r--r--config.mk33
3 files changed, 38 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2cf4b3adf23b..75e9f3209c4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -15,6 +15,7 @@ pkgbase = st-monosans-git
provides = st
conflicts = st
source = git://github.com/monosans/st
+ source = config.mk
sha256sums = SKIP
pkgname = st-monosans-git
diff --git a/PKGBUILD b/PKGBUILD
index 842fca48661f..0dcc67ad760a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,12 +4,13 @@ pkgname=st-monosans-git
pkgver=0.8.4.r1141.966386b
pkgrel=1
pkgdesc='Simple (suckless) terminal with scrollback, ligatures and One Dark color scheme'
-url="https://github.com/monosans/st"
+url=https://github.com/monosans/st
arch=(i686 x86_64)
license=(MIT)
depends=(libxft harfbuzz ttf-jetbrains-mono)
makedepends=(git libxext ncurses)
-source=("git://github.com/monosans/st")
+source=(git://github.com/monosans/st
+ config.mk)
sha256sums=('SKIP')
provides=(st)
conflicts=(st)
@@ -21,6 +22,7 @@ pkgver() {
}
prepare() {
+ cp "$BUILDDIR/config.mk" "$_sourcedir"
cd st
sed -i '/tic /d' Makefile
}
diff --git a/config.mk b/config.mk
new file mode 100644
index 000000000000..11c62368b502
--- /dev/null
+++ b/config.mk
@@ -0,0 +1,33 @@
+# st version
+VERSION = 0.8.4
+
+# Customize below to fit your system
+
+# paths
+PREFIX = /usr/local
+
+X11INC = /usr/X11R6/include
+X11LIB = /usr/X11R6/lib
+
+PKG_CONFIG = pkg-config
+
+# includes and libs
+INCS = -I$(X11INC) \
+ `$(PKG_CONFIG) --cflags fontconfig` \
+ `$(PKG_CONFIG) --cflags freetype2` \
+ `$(PKG_CONFIG) --cflags harfbuzz`
+LIBS = -L$(X11LIB) -lm -lrt -lX11 -lutil -lXft \
+ `$(PKG_CONFIG) --libs fontconfig` \
+ `$(PKG_CONFIG) --libs freetype2` \
+ `$(PKG_CONFIG) --libs harfbuzz`
+
+# flags
+STCPPFLAGS = -DVERSION=\"$(VERSION)\" -D_XOPEN_SOURCE=600
+STCFLAGS = $(INCS) $(STCPPFLAGS) $(CPPFLAGS) $(CFLAGS)
+STLDFLAGS = $(LIBS) $(LDFLAGS)
+
+# OpenBSD:
+#CPPFLAGS = -DVERSION=\"$(VERSION)\" -D_XOPEN_SOURCE=600 -D_BSD_SOURCE
+
+# compiler and linker
+# CC = c99