summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSergey Musiyenko2020-06-11 14:05:12 +0200
committerSergey Musiyenko2020-06-11 14:05:12 +0200
commit4e92b0556e8b387de1b1d499a8980580c67f8128 (patch)
tree88485dfda28d9572990d5053ca74ee8a77433ab7
downloadaur-4e92b0556e8b387de1b1d499a8980580c67f8128.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd460bed0c32
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = st-musiyenko-git
+ pkgdesc = Simple terminal implementation for X
+ pkgver = 0.8.3.r6.417ff45
+ pkgrel = 1
+ url = https://github.com/musiyenko/st
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = ncurses
+ makedepends = libxext
+ depends = libxft
+ provides = st
+ conflicts = st
+ source = st-musiyenko::git+https://github.com/musiyenko/st
+ md5sums = SKIP
+
+pkgname = st-musiyenko-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e13e8f7845b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Sergey Musiyenko <m@sy.mk>
+pkgname=st-musiyenko-git
+_pkgname=st-musiyenko
+pkgver=0.8.3.r6.417ff45
+pkgrel=1
+pkgdesc="Simple terminal implementation for X"
+arch=('i686' 'x86_64')
+url="https://github.com/musiyenko/st"
+license=('MIT')
+depends=('libxft')
+makedepends=('git' 'ncurses' 'libxext')
+provides=('st')
+conflicts=('st')
+source=("${_pkgname}::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${_pkgname}"
+ _pkgver=$(awk '/VERSION/ {print $3}' config.mk|head -1)
+ echo "${_pkgver}.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "${_pkgname}"
+}
+
+build() {
+ cd "${_pkgname}"
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd "${_pkgname}"
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+}