summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpicokan2020-08-10 18:45:35 +0100
committerpicokan2020-08-10 18:45:35 +0100
commitfc2f3ed70e1bdc64908b8628020a437ed0583067 (patch)
treec34937828d00fb7445c087492a0aaf10ccd44239
parent422ea2a82f0d2b7bfcc434529bd4bcf7a26ee815 (diff)
downloadaur-fc2f3ed70e1bdc64908b8628020a437ed0583067.tar.gz
Added quotes around directory paths that may break if path has spaces in it. Changed diff file directories to be generic 'a's and 'b's.
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--sane-defaults-patch.diff43
3 files changed, 27 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c40194569460..8b2648fe64c8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = st-sane-defaults
pkgdesc = A simple terminal emulator, with configurations fit for the average user.
pkgver = 0.8.2
- pkgrel = 3
+ pkgrel = 4
url = https://st.suckless.org
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 28dcf065ec28..ce698e935085 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=st-sane-defaults
_pkgname=st
pkgver=0.8.2
-pkgrel=3
+pkgrel=4
pkgdesc='A simple terminal emulator, with configurations fit for the average user.'
arch=('i686' 'x86_64' 'armv7h')
license=('MIT')
@@ -13,8 +13,8 @@ source=(https://dl.suckless.org/$_pkgname/$_pkgname-$pkgver.tar.gz
sane-defaults-patch.diff
st-sane-defaults.desktop)
sha256sums=('aeb74e10aa11ed364e1bcc635a81a523119093e63befd2f231f8b0705b15bf35'
- '15fa8e3fd172bc25ea52d3532ac01edb88877c9af2cb8de140d178507ac9c552'
- '17924fbac300031b0f8b0bbbf85d18c4637a78e7260350714d4062d64783d46d')
+ '15fa8e3fd172bc25ea52d3532ac01edb88877c9af2cb8de140d178507ac9c552'
+ '17924fbac300031b0f8b0bbbf85d18c4637a78e7260350714d4062d64783d46d')
provides=("st")
conflicts=("st")
@@ -23,12 +23,12 @@ prepare() {
}
build() {
- cd $srcdir/$_pkgname-$pkgver
+ cd "$srcdir/$_pkgname-$pkgver"
make
}
package() {
- cd $srcdir/$_pkgname-$pkgver
+ cd "$srcdir/$_pkgname-$pkgver"
make DESTDIR="$pkgdir" install
install -Dm644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
diff --git a/sane-defaults-patch.diff b/sane-defaults-patch.diff
index f26b31404a1c..adb29372efea 100644
--- a/sane-defaults-patch.diff
+++ b/sane-defaults-patch.diff
@@ -1,6 +1,6 @@
-diff -r -u /home/user/Desktop/st-0.8.2/config.def.h /mnt/LMule/repo/st/src/st-0.8.2/config.def.h
---- /home/user/Desktop/st-0.8.2/config.def.h 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/config.def.h 2020-08-04 23:03:43.373968106 +0100
+diff -r -u a/config.def.h b/config.def.h
+--- a/config.def.h 2019-02-09 11:50:41.000000000 +0000
++++ b/config.def.h 2020-08-04 23:03:43.373968106 +0100
@@ -5,7 +5,7 @@
*
* font: see http://freedesktop.org/software/fontconfig/fontconfig-user.html
@@ -110,10 +110,10 @@ diff -r -u /home/user/Desktop/st-0.8.2/config.def.h /mnt/LMule/repo/st/src/st-0.
{ XK_BackSpace, Mod1Mask, "\033\177", 0, 0},
{ XK_Home, ShiftMask, "\033[2J", 0, -1},
{ XK_Home, ShiftMask, "\033[1;2H", 0, +1},
-Só em /mnt/LMule/repo/st/src/st-0.8.2: config.h
-diff -r -u /home/user/Desktop/st-0.8.2/config.mk /mnt/LMule/repo/st/src/st-0.8.2/config.mk
---- /home/user/Desktop/st-0.8.2/config.mk 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/config.mk 2020-08-04 23:04:59.477301512 +0100
+
+diff -r -u a/config.mk b/config.mk
+--- a/config.mk 2019-02-09 11:50:41.000000000 +0000
++++ b/config.mk 2020-08-04 23:04:59.477301512 +0100
@@ -4,7 +4,7 @@
# Customize below to fit your system
@@ -132,10 +132,10 @@ diff -r -u /home/user/Desktop/st-0.8.2/config.mk /mnt/LMule/repo/st/src/st-0.8.2
`$(PKG_CONFIG) --libs fontconfig` \
`$(PKG_CONFIG) --libs freetype2`
-Só em /mnt/LMule/repo/st/src/st-0.8.2: st
-diff -r -u /home/user/Desktop/st-0.8.2/st.c /mnt/LMule/repo/st/src/st-0.8.2/st.c
---- /home/user/Desktop/st-0.8.2/st.c 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/st.c 2020-08-04 23:03:43.373968106 +0100
+
+diff -r -u a/st.c b/st.c
+--- a/st.c 2019-02-09 11:50:41.000000000 +0000
++++ b/st.c 2020-08-04 23:03:43.373968106 +0100
@@ -35,6 +35,7 @@
#define ESC_ARG_SIZ 16
#define STR_BUF_SIZ ESC_BUF_SIZ
@@ -451,9 +451,9 @@ diff -r -u /home/user/Desktop/st-0.8.2/st.c /mnt/LMule/repo/st/src/st-0.8.2/st.c
term.ocx, term.ocy, term.line[term.ocy][term.ocx]);
term.ocx = cx, term.ocy = term.c.y;
xfinishdraw();
-diff -r -u /home/user/Desktop/st-0.8.2/st.h /mnt/LMule/repo/st/src/st-0.8.2/st.h
---- /home/user/Desktop/st-0.8.2/st.h 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/st.h 2020-08-04 23:03:43.373968106 +0100
+diff -r -u a/st.h b/st.h
+--- a/st.h 2019-02-09 11:50:41.000000000 +0000
++++ b/st.h 2020-08-04 23:03:43.373968106 +0100
@@ -76,16 +76,26 @@
const void *v;
} Arg;
@@ -487,9 +487,9 @@ diff -r -u /home/user/Desktop/st-0.8.2/st.h /mnt/LMule/repo/st/src/st-0.8.2/st.h
extern unsigned int defaultbg;
+extern MouseKey mkeys[];
+extern float alpha;
-diff -r -u /home/user/Desktop/st-0.8.2/st.info /mnt/LMule/repo/st/src/st-0.8.2/st.info
---- /home/user/Desktop/st-0.8.2/st.info 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/st.info 2020-08-04 23:03:43.377301440 +0100
+diff -r -u a/st.info b/st.info
+--- a/st.info 2019-02-09 11:50:41.000000000 +0000
++++ b/st.info 2020-08-04 23:03:43.377301440 +0100
@@ -54,7 +54,7 @@
ka3=\E[5~,
kc1=\E[4~,
@@ -508,10 +508,10 @@ diff -r -u /home/user/Desktop/st-0.8.2/st.info /mnt/LMule/repo/st/src/st-0.8.2/s
kich1=\E[2~,
kend=\E[4~,
kf1=\EOP,
-Só em /mnt/LMule/repo/st/src/st-0.8.2: st.o
-diff -r -u /home/user/Desktop/st-0.8.2/x.c /mnt/LMule/repo/st/src/st-0.8.2/x.c
---- /home/user/Desktop/st-0.8.2/x.c 2019-02-09 11:50:41.000000000 +0000
-+++ /mnt/LMule/repo/st/src/st-0.8.2/x.c 2020-08-04 23:03:43.377301440 +0100
+
+diff -r -u a/x.c b/x.c
+--- a/x.c 2019-02-09 11:50:41.000000000 +0000
++++ b/x.c 2020-08-04 23:03:43.377301440 +0100
@@ -98,6 +98,7 @@
XSetWindowAttributes attrs;
int scr;
@@ -662,4 +662,3 @@ diff -r -u /home/user/Desktop/st-0.8.2/x.c /mnt/LMule/repo/st/src/st-0.8.2/x.c
case 'c':
opt_class = EARGF(usage());
break;
-Só em /mnt/LMule/repo/st/src/st-0.8.2: x.o