aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Ornbo2015-06-08 22:18:31 +0100
committerGeorge Ornbo2015-06-08 22:18:31 +0100
commit147e63b35eade20828e75a029c37b1eceff8d426 (patch)
tree2d271f0c8348db9876f0e6868b788d62246b5c46
downloadaur-147e63b35eade20828e75a029c37b1eceff8d426.tar.gz
initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD38
-rw-r--r--README.md10
4 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75b4050b29ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = st-solarized-dark
+ pkgdesc = A simple virtual terminal emulator for X.
+ pkgver = 0.5
+ pkgrel = 1
+ url = http://st.suckless.org
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = ncurses
+ depends = libxext
+ depends = libxft
+ source = http://dl.suckless.org/st/st-0.5.tar.gz
+ source = http://st.suckless.org/patches/st-0.5-no-bold-colors.diff
+ source = http://st.suckless.org/patches/st-solarized-light.diff
+ md5sums = 4f8ae2737120a8cba34b23c6020fe51e
+ md5sums = 18c28fc0ff19de6c2e4a58a711c91b15
+ md5sums = 5e27e1fb2831af457519a345ef477af3
+
+pkgname = st-solarized-dark
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..c2243abe132f
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 George Ornbo
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..050d67a66e12
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: George Ornbo <george@shapeshed.com>
+
+pkgname=st-solarized-dark
+pkgver=0.5
+pkgrel=1
+pkgdesc='A simple virtual terminal emulator for X.'
+arch=('i686' 'x86_64')
+license=('MIT')
+depends=('libxext' 'libxft')
+makedepends=('ncurses')
+url="http://st.suckless.org"
+source=(http://dl.suckless.org/st/$pkgname-$pkgver.tar.gz
+ http://st.suckless.org/patches/st-0.5-no-bold-colors.diff
+ http://st.suckless.org/patches/st-solarized-light.diff)
+
+md5sums=('4f8ae2737120a8cba34b23c6020fe51e'
+ '18c28fc0ff19de6c2e4a58a711c91b15'
+ '5e27e1fb2831af457519a345ef477af3')
+
+prepare() {
+ cd $srcdir/$pkgname-$pkgver
+ patch -p1 -i ../st-$pkgver-no-bold-colors.diff
+ patch -p1 -i ../st-solarized-light.diff
+ cp config.def.h config.h
+ sed -i 's/Liberation Mono:pixelsize=12:antialias=false:autohint=false/Inconsolata:pixelsize=16:antialias=true:autohint=true/' config.h
+}
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make PREFIX=/usr DESTDIR="$pkgdir" TERMINFO="$pkgdir/usr/share/terminfo" install
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README "$pkgdir/usr/share/doc/$pkgname/README"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..7299a7eb24c2
--- /dev/null
+++ b/README.md
@@ -0,0 +1,10 @@
+# st-solarized-light
+
+An ArchLinux PKGBUILD for [st][1] with patches applied [Solarized][2] dark theme.
+
+This also sets the font to [Inconsolata][3] 16.
+
+[1]: http://st.suckless.org/
+[2]: http://ethanschoonover.com/solarized
+[3]: http://www.levien.com/type/myfonts/inconsolata.html
+