summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-09-18 22:26:08 -0600
committerBrian Bidulock2015-09-18 22:26:08 -0600
commitad5b78d3601ecb3ead7e81cb01e0b4f100005fdc (patch)
treeff4ba3e456456bdd96032bc57c5c79097a43bf3f
parentecd082c65e71def505a3f02c95c964d276d5bfe8 (diff)
downloadaur-ad5b78d3601ecb3ead7e81cb01e0b4f100005fdc.tar.gz
version 0.6.r32.gbf8c71e-1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD72
-rw-r--r--config.h31
3 files changed, 68 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db1716aa0f25..ee522666a885 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = st-white-git
pkgdesc = A simple virtual terminal emulator for X.
- pkgver = 0.6.r13.gd032b61
+ pkgver = 0.6.r32.gbf8c71e
pkgrel = 1
url = http://st.suckless.org
arch = i686
@@ -12,10 +12,10 @@ pkgbase = st-white-git
depends = libxft
provides = st
conflicts = st
- source = git://git.suckless.org/st
+ source = st-white-git::git://git.suckless.org/st
source = config.h
md5sums = SKIP
- md5sums = 63512eae3f0018abdaa5b39bb01c0900
+ md5sums = c3cd89ac96406c7c5381a7d1eb65ede0
pkgname = st-white-git
diff --git a/PKGBUILD b/PKGBUILD
index b75230ed3c66..714881bb9e06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,9 @@
pkgname=st-white-git
_pkgname=st
-pkgver=0.6.r13.gd032b61
+pkgver=0.6.r32.gbf8c71e
pkgrel=1
+
pkgdesc='A simple virtual terminal emulator for X.'
arch=('i686' 'x86_64')
url="http://st.suckless.org"
@@ -13,52 +14,51 @@ conflicts=($_pkgname)
provides=($_pkgname)
depends=('libxft')
makedepends=('ncurses' 'libxext' 'git')
-source=("git://git.suckless.org/st"
+source=("$pkgname::git://git.suckless.org/st"
'config.h')
md5sums=('SKIP'
- '63512eae3f0018abdaa5b39bb01c0900')
+ 'c3cd89ac96406c7c5381a7d1eb65ede0')
pkgver() {
- cd "${srcdir}/${_pkgname}"
- git describe --tags --long|sed -r 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
+ cd $pkgname
+ git describe --tags --long|sed -r 's,^[^0-9]*,,;s,([^-]*-g),r\1,;s,[-_],.,g'
}
prepare() {
- local file
- cd "${srcdir}/${_pkgname}"
- sed \
- -e '/char font/s/= .*/= "Fixed:pixelsize=13:style=SemiCondensed";/' \
- -e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
- -e '/int defaultcs/s/= .*/= 1;/' \
- -i config.def.h
- sed \
- -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
- -e 's/CFLAGS =/CFLAGS +=/g' \
- -e 's/LDFLAGS =/LDFLAGS +=/g' \
- -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
- -i config.mk
- sed '/@tic/d' -i Makefile
- for file in "${source[@]}"; do
- if [[ "$file" != *.diff ]]; then
- # add config.h if present in source array
- # Note: this supersedes the above sed to config.def.h
- [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" .
- continue
- fi
- # add all patches present in source array
- patch -Np1 <"$SRCDEST/$file"
- done
+ local file
+ cd $pkgname
+ sed \
+ -e '/char font/s/= .*/= "Fixed:pixelsize=13:style=SemiCondensed";/' \
+ -e '/char worddelimiters/s/= .*/= " '"'"'`\\\"()[]{}<>|";/' \
+ -e '/int defaultcs/s/= .*/= 1;/' \
+ -i config.def.h
+ sed \
+ -e 's/CPPFLAGS =/CPPFLAGS +=/g' \
+ -e 's/CFLAGS =/CFLAGS +=/g' \
+ -e 's/LDFLAGS =/LDFLAGS +=/g' \
+ -e 's/_BSD_SOURCE/_DEFAULT_SOURCE/' \
+ -i config.mk
+ sed '/@tic/d' -i Makefile
+ for file in "${source[@]}"; do
+ if [[ "$file" != *.diff ]]; then
+ # add config.h if present in source array
+ # Note: this supersedes the above sed to config.def.h
+ [[ "$file" == "config.h" ]] && cp "$SRCDEST/$file" .
+ continue
+ fi
+ # add all patches present in source array
+ patch -Np1 <"$SRCDEST/$file"
+ done
}
build() {
- cd "${srcdir}/${_pkgname}"
- make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+ cd $pkgname
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
}
package() {
- cd "${srcdir}/${_pkgname}"
- make PREFIX=/usr DESTDIR="${pkgdir}" install
- install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
- tic -s -o "${pkgdir}/usr/share/terminfo" st.info
+ cd $pkgname
+ make PREFIX=/usr DESTDIR="${pkgdir}" install
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
}
diff --git a/config.h b/config.h
index 606846fb4cf0..b62f77152745 100644
--- a/config.h
+++ b/config.h
@@ -5,11 +5,20 @@
*
* font: see http://freedesktop.org/software/fontconfig/fontconfig-user.html
*/
-static char font[] = "Liberation Mono:size=9pt:antialias=true:autohint=false";
+static char font[] = "Liberation Mono:size=9pt:antialias=true:autohint=true";
static int borderpx = 2;
+
+/*
+ * What program is execed by st depends of these precedence rules:
+ * 1: program passed with -e
+ * 2: utmp option
+ * 3: SHELL environment variable
+ * 4: value of shell in /etc/passwd
+ * 5: value of shell in config.h
+ */
static char shell[] = "/bin/sh";
static char *utmp = NULL;
-static char stty_args[] = "stty raw -echo -iexten echonl";
+static char stty_args[] = "stty raw pass8 nl -echo -iexten -cstopb 38400";
/* identification sequence returned in DA and DECID */
static char vtiden[] = "\033[?6c";
@@ -104,6 +113,23 @@ static unsigned int defaultbg = 15;
static unsigned int defaultcs = 21;
/*
+ * Default shape of cursor
+ * 2: Block
+ * 4: Underline
+ * 6: IBeam
+ */
+
+static unsigned int cursorshape = 2;
+
+
+/*
+ * Default colour and shape of the mouse cursor
+ */
+static unsigned int mouseshape = XC_xterm;
+static unsigned int mousefg = 17;
+static unsigned int mousebg = 15;
+
+/*
* Colors used, when the specific fg == defaultfg. So in reverse mode this
* will reverse too. Another logic would only make the simple feature too
* complex.
@@ -124,6 +150,7 @@ static Mousekey mshortcuts[] = {
static Shortcut shortcuts[] = {
/* mask keysym function argument */
+ { XK_ANY_MOD, XK_Break, sendbreak, {.i = 0} },
{ ControlMask, XK_Print, toggleprinter, {.i = 0} },
{ ShiftMask, XK_Print, printscreen, {.i = 0} },
{ XK_ANY_MOD, XK_Print, printsel, {.i = 0} },