summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorymber2020-06-26 11:52:13 +0100
committerymber2020-06-26 11:59:06 +0100
commit334e2083822ef3802b05506053c651939d5954db (patch)
tree089fdf7e6a6824a96da53cbcf55ff0e00f25f6f1
parent22886d148a6aa7cbde4458ab7424087b0f2396b1 (diff)
downloadaur-334e2083822ef3802b05506053c651939d5954db.tar.gz
Update to st 0.8.4
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD14
-rw-r--r--st-no-bold-colors-0.8.4.diff (renamed from st-no_bold_colors-0.8.2.diff)4
-rw-r--r--st-solarized-dark-0.8.4.diff (renamed from st-solarized-dark-0.8.2.diff)8
-rw-r--r--st-yutna-0.8.4.diff (renamed from st-yutna-0.8.2.diff)5
5 files changed, 24 insertions, 25 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb21aae9b56d..580c0e9a3547 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = st-yutna
pkgdesc = Simple terminal emulator.
- pkgver = 0.8.2
+ pkgver = 0.8.4
pkgrel = 1
url = https://st.suckless.org/
arch = x86_64
@@ -8,14 +8,14 @@ pkgbase = st-yutna
depends = libxft
depends = ttf-roboto-mono
provides = st
- source = https://dl.suckless.org/st/st-0.8.2.tar.gz
- source = st-yutna-0.8.2.diff
- source = st-no_bold_colors-0.8.2.diff
- source = st-solarized-dark-0.8.2.diff
- sha256sums = aeb74e10aa11ed364e1bcc635a81a523119093e63befd2f231f8b0705b15bf35
- sha256sums = 4e6ae20701290278bb9f4c1243a40d85b6bcc83d8478df964867df6c9b38fe8e
- sha256sums = 8879e5a0dd1b529e5dc6905ae8b64b217f3b85f1a1d3c9d69e23f752c5539b6b
- sha256sums = 1f5aa16f454a413b2f9c4e7f67e7b620607178365fdd0f15e62ba3922f9b531d
+ source = https://dl.suckless.org/st/st-0.8.4.tar.gz
+ source = st-yutna-0.8.4.diff
+ source = st-no-bold-colors-0.8.4.diff
+ source = st-solarized-dark-0.8.4.diff
+ sha256sums = d42d3ceceb4d6a65e32e90a5336e3d446db612c3fbd9ebc1780bc6c9a03346a6
+ sha256sums = 681b24332e93fbe6a48a6440a682f51db69e43f9ad606a8c2d657bbad409cde2
+ sha256sums = 4edca37de88f0c39e2686153f1180252af1d4c47b202cebea01e2776e25bac4a
+ sha256sums = 9aa1095d208bdf38f26d4fa49d690210c3111e78a299ccac4b89097c176bd8c8
pkgname = st-yutna
diff --git a/PKGBUILD b/PKGBUILD
index 44eecc109000..5ad649bbc4cc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=st-yutna
_pkgname=st
-pkgver=0.8.2
+pkgver=0.8.4
pkgrel=1
pkgdesc="Simple terminal emulator."
arch=("x86_64")
@@ -12,17 +12,17 @@ depends=("libxft" "ttf-roboto-mono")
provides=("st")
source=(https://dl.suckless.org/st/$_pkgname-$pkgver.tar.gz
st-yutna-$pkgver.diff
- st-no_bold_colors-$pkgver.diff
+ st-no-bold-colors-$pkgver.diff
st-solarized-dark-$pkgver.diff)
-sha256sums=("aeb74e10aa11ed364e1bcc635a81a523119093e63befd2f231f8b0705b15bf35"
- "4e6ae20701290278bb9f4c1243a40d85b6bcc83d8478df964867df6c9b38fe8e"
- "8879e5a0dd1b529e5dc6905ae8b64b217f3b85f1a1d3c9d69e23f752c5539b6b"
- "1f5aa16f454a413b2f9c4e7f67e7b620607178365fdd0f15e62ba3922f9b531d")
+sha256sums=("d42d3ceceb4d6a65e32e90a5336e3d446db612c3fbd9ebc1780bc6c9a03346a6"
+ "681b24332e93fbe6a48a6440a682f51db69e43f9ad606a8c2d657bbad409cde2"
+ "4edca37de88f0c39e2686153f1180252af1d4c47b202cebea01e2776e25bac4a"
+ "9aa1095d208bdf38f26d4fa49d690210c3111e78a299ccac4b89097c176bd8c8")
prepare() {
cd $srcdir/$_pkgname-$pkgver
patch -p1 -i $srcdir/st-yutna-$pkgver.diff
- patch -p1 -i $srcdir/st-no_bold_colors-$pkgver.diff
+ patch -p1 -i $srcdir/st-no-bold-colors-$pkgver.diff
patch -p1 -i $srcdir/st-solarized-dark-$pkgver.diff
}
diff --git a/st-no_bold_colors-0.8.2.diff b/st-no-bold-colors-0.8.4.diff
index fa4b7279945a..76146b6c5d41 100644
--- a/st-no_bold_colors-0.8.2.diff
+++ b/st-no-bold-colors-0.8.4.diff
@@ -1,8 +1,8 @@
diff --git a/x.c b/x.c
-index 0422421..904e1dc 100644
+index 210f184..f8e4f99 100644
--- a/x.c
+++ b/x.c
-@@ -1296,10 +1296,6 @@ xdrawglyphfontspecs(const XftGlyphFontSpec *specs, Glyph base, int len, int x, i
+@@ -1380,10 +1380,6 @@ xdrawglyphfontspecs(const XftGlyphFontSpec *specs, Glyph base, int len, int x, i
bg = &dc.col[base.bg];
}
diff --git a/st-solarized-dark-0.8.2.diff b/st-solarized-dark-0.8.4.diff
index 00ef4343b887..87c810e38f56 100644
--- a/st-solarized-dark-0.8.2.diff
+++ b/st-solarized-dark-0.8.4.diff
@@ -1,8 +1,8 @@
diff --git a/config.def.h b/config.def.h
-index 0e01717..0fe81d4 100644
+index 6f05dce..6df36e2 100644
--- a/config.def.h
+++ b/config.def.h
-@@ -84,31 +84,23 @@ unsigned int tabspaces = 8;
+@@ -95,31 +95,23 @@ unsigned int tabspaces = 8;
/* Terminal colors (16 first used in escape sequence) */
static const char *colorname[] = {
@@ -31,7 +31,7 @@ index 0e01717..0fe81d4 100644
- /* more colors can be added after 255 to use with DefaultXX */
- "#cccccc",
- "#555555",
-+ /* solarized dark */
++ /* solarized dark */
+ "#073642", /* 0: black */
+ "#dc322f", /* 1: red */
+ "#859900", /* 2: green */
@@ -51,7 +51,7 @@ index 0e01717..0fe81d4 100644
};
-@@ -116,10 +108,10 @@ static const char *colorname[] = {
+@@ -127,10 +119,10 @@ static const char *colorname[] = {
* Default colors (colorname index)
* foreground, background, cursor, reverse cursor
*/
diff --git a/st-yutna-0.8.2.diff b/st-yutna-0.8.4.diff
index 36733478c4c9..52513df74d7d 100644
--- a/st-yutna-0.8.2.diff
+++ b/st-yutna-0.8.4.diff
@@ -1,5 +1,5 @@
diff --git a/config.def.h b/config.def.h
-index 0e01717..10ffc1d 100644
+index 6df36e2..323146d 100644
--- a/config.def.h
+++ b/config.def.h
@@ -5,7 +5,7 @@
@@ -11,7 +11,7 @@ index 0e01717..10ffc1d 100644
static int borderpx = 2;
/*
-@@ -134,8 +134,8 @@ static unsigned int cursorshape = 2;
+@@ -137,8 +137,8 @@ static unsigned int cursorshape = 2;
* Default columns and rows numbers
*/
@@ -22,4 +22,3 @@ index 0e01717..10ffc1d 100644
/*
* Default colour and shape of the mouse cursor
- \ No newline at end of file