summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorymber2018-12-29 14:03:02 +0000
committerymber2018-12-29 14:03:02 +0000
commitafa578b7b3205ee080e6a402ac16220bde47bba1 (patch)
tree6f2c4478c2fbb356e04f060f891c6c1ff2be10a2
downloadaur-afa578b7b3205ee080e6a402ac16220bde47bba1.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD37
-rw-r--r--st-solarized-dark-0.8.1.diff68
-rw-r--r--st-yutna-0.8.1.diff24
4 files changed, 147 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..938f6a2315ec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = st-yutna
+ pkgdesc = Simple terminal emulator.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://st.suckless.org/
+ arch = x86_64
+ license = MIT
+ depends = libxft
+ provides = st
+ source = https://dl.suckless.org/st/st-0.8.1.tar.gz
+ source = st-yutna-0.8.1.diff
+ source = st-solarized-dark-0.8.1.diff
+ sha256sums = c4fb0fe2b8d2d3bd5e72763e80a8ae05b7d44dbac8f8e3bb18ef0161c7266926
+ sha256sums = 499c4aed075dcb4198f50a6b0da17e111ebd6b8e26925659e4b53dc29b87d99b
+ sha256sums = b2d5e88a2616eafb82b2fefb63eecb0f9d71f839349ef40f9f69c1953444f88c
+
+pkgname = st-yutna
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..86b9fb62cd3c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Matthew Taylor <mtaylor1252dev@gmail.com>
+
+pkgname=st-yutna
+_pkgname=st
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Simple terminal emulator."
+arch=("x86_64")
+url="https://st.suckless.org/"
+license=("MIT")
+depends=("libxft")
+provides=("st")
+source=(https://dl.suckless.org/st/$_pkgname-$pkgver.tar.gz
+ st-yutna-0.8.1.diff
+ st-solarized-dark-0.8.1.diff)
+sha256sums=("c4fb0fe2b8d2d3bd5e72763e80a8ae05b7d44dbac8f8e3bb18ef0161c7266926"
+ "499c4aed075dcb4198f50a6b0da17e111ebd6b8e26925659e4b53dc29b87d99b"
+ "b2d5e88a2616eafb82b2fefb63eecb0f9d71f839349ef40f9f69c1953444f88c")
+
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ patch -p1 -i $srcdir/st-yutna-0.8.1.diff
+ patch -p1 -i $srcdir/st-solarized-dark-0.8.1.diff
+}
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ make X11INC=/usr/include/X11 X11LIB=/usr/lib/X11
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+ make PREFIX=/usr DESTDIR=$pkgdir install
+ install -Dm644 LICENSE $pkgdir/usr/share/licenses/$_pkgname/LICENSE
+ install -Dm644 README $pkgdir/usr/share/doc/$_pkgname/README
+}
+
diff --git a/st-solarized-dark-0.8.1.diff b/st-solarized-dark-0.8.1.diff
new file mode 100644
index 000000000000..241fef44943e
--- /dev/null
+++ b/st-solarized-dark-0.8.1.diff
@@ -0,0 +1,68 @@
+diff --git a/config.def.h b/config.def.h
+index 82b1b09..6065bb6 100644
+--- a/config.def.h
++++ b/config.def.h
+@@ -84,31 +84,23 @@ unsigned int tabspaces = 8;
+
+ /* Terminal colors (16 first used in escape sequence) */
+ static const char *colorname[] = {
+- /* 8 normal colors */
+- "black",
+- "red3",
+- "green3",
+- "yellow3",
+- "blue2",
+- "magenta3",
+- "cyan3",
+- "gray90",
+-
+- /* 8 bright colors */
+- "gray50",
+- "red",
+- "green",
+- "yellow",
+- "#5c5cff",
+- "magenta",
+- "cyan",
+- "white",
+-
+- [255] = 0,
+-
+- /* more colors can be added after 255 to use with DefaultXX */
+- "#cccccc",
+- "#555555",
++ /* solarized dark */
++ "#073642", /* 0: black */
++ "#dc322f", /* 1: red */
++ "#859900", /* 2: green */
++ "#b58900", /* 3: yellow */
++ "#268bd2", /* 4: blue */
++ "#d33682", /* 5: magenta */
++ "#2aa198", /* 6: cyan */
++ "#eee8d5", /* 7: white */
++ "#002b36", /* 8: brblack */
++ "#cb4b16", /* 9: brred */
++ "#586e75", /* 10: brgreen */
++ "#657b83", /* 11: bryellow */
++ "#839496", /* 12: brblue */
++ "#6c71c4", /* 13: brmagenta*/
++ "#93a1a1", /* 14: brcyan */
++ "#fdf6e3", /* 15: brwhite */
+ };
+
+
+@@ -116,10 +108,10 @@ static const char *colorname[] = {
+ * Default colors (colorname index)
+ * foreground, background, cursor, reverse cursor
+ */
+-unsigned int defaultfg = 7;
+-unsigned int defaultbg = 0;
+-static unsigned int defaultcs = 256;
+-static unsigned int defaultrcs = 257;
++unsigned int defaultfg = 12;
++unsigned int defaultbg = 8;
++static unsigned int defaultcs = 14;
++static unsigned int defaultrcs = 15;
+
+ /*
+ * Default shape of cursor
diff --git a/st-yutna-0.8.1.diff b/st-yutna-0.8.1.diff
new file mode 100644
index 000000000000..84f99fad137b
--- /dev/null
+++ b/st-yutna-0.8.1.diff
@@ -0,0 +1,24 @@
+diff --git a/config.def.h b/config.def.h
+index 82b1b09..456b1a9 100644
+--- a/config.def.h
++++ b/config.def.h
+@@ -5,7 +5,7 @@
+ *
+ * font: see http://freedesktop.org/software/fontconfig/fontconfig-user.html
+ */
+-static char *font = "Liberation Mono:pixelsize=12:antialias=true:autohint=true";
++static char *font = "Roboto Mono:pixelsize=14:antialias=true:autohint=true";
+ static int borderpx = 2;
+
+ /*
+@@ -134,8 +134,8 @@ static unsigned int cursorshape = 2;
+ * Default columns and rows numbers
+ */
+
+-static unsigned int cols = 80;
+-static unsigned int rows = 24;
++static unsigned int cols = 120;
++static unsigned int rows = 34;
+
+ /*
+ * Default colour and shape of the mouse cursor