summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhil Ruffwind2017-08-31 14:36:58 -0400
committerPhil Ruffwind2017-08-31 14:40:05 -0400
commitb5bbfd5d19182fcb579cdec401928d244f1871a1 (patch)
treec91a0b72cb86347997f591800dfc0fc85d60581a
downloadaur-b5bbfd5d19182fcb579cdec401928d244f1871a1.tar.gz
1.5.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD21
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9971e406fa38
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Thu Aug 31 18:40:05 UTC 2017
+pkgbase = stack-bin
+ pkgdesc = The Haskell Tool Stack (tool only -- libraries not included)
+ pkgver = 1.5.1
+ pkgrel = 1
+ url = https://hackage.haskell.org/package/stack
+ arch = i686
+ arch = x86_64
+ license = BSD3
+ depends = gmp
+ depends = zlib
+ provides = stack
+ conflicts = stack
+ source_i686 = https://github.com/commercialhaskell/stack/releases/download/v1.5.1/stack-1.5.1-linux-i386.tar.gz
+ sha256sums_i686 = 2973f7baab2f557c113a92a560ad79b887bd57102e8f4a5caf67551a42ea4250
+ source_x86_64 = https://github.com/commercialhaskell/stack/releases/download/v1.5.1/stack-1.5.1-linux-x86_64.tar.gz
+ sha256sums_x86_64 = b7df551c2f67464bebc5859fc0ecb2dc59cdbeb525af09e05ea4f2752828e542
+
+pkgname = stack-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4eb1d0e0ef9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Phil Ruffwind <rf@rufflewind.com>
+pkgname=stack-bin
+pkgver=1.5.1
+pkgrel=1
+pkgdesc="The Haskell Tool Stack (tool only -- libraries not included)"
+arch=(i686 x86_64)
+url=https://hackage.haskell.org/package/stack
+license=(BSD3)
+depends=(gmp zlib)
+provides=(stack)
+conflicts=(stack)
+source_i686=(https://github.com/commercialhaskell/stack/releases/download/v$pkgver/stack-$pkgver-linux-i386.tar.gz)
+source_x86_64=(https://github.com/commercialhaskell/stack/releases/download/v$pkgver/stack-$pkgver-linux-x86_64.tar.gz)
+sha256sums_i686=('2973f7baab2f557c113a92a560ad79b887bd57102e8f4a5caf67551a42ea4250')
+sha256sums_x86_64=('b7df551c2f67464bebc5859fc0ecb2dc59cdbeb525af09e05ea4f2752828e542')
+
+package() {
+ cd "$srcdir/stack-$pkgver-linux-"*/
+ install -Dm755 stack "$pkgdir/usr/bin/stack"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/stack/LICENSE"
+}