summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRuben Van Boxem2020-06-20 23:46:51 +0200
committerRuben Van Boxem2020-06-20 23:46:51 +0200
commitafb94c9a880cfc78b4621bce75907caa6759a650 (patch)
treec7c4fb8a68694fb6d6e6f8f769c2b7abfa8de752
parent4a3e66e68bb1742a75efc499e17a449ad5215857 (diff)
downloadaur-afb94c9a880cfc78b4621bce75907caa6759a650.tar.gz
Fix build with Qt 5.15.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--qt5.15_missing_qpainterpath_include.patch11
3 files changed, 20 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f79c4021df49..6aca382812c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stack-client
pkgdesc = The STACK Client provides file sync to desktop clients.
pkgver = 2.6.4
- pkgrel = 1
+ pkgrel = 2
url = https://www.transip.nl/stack/
arch = x86_64
license = GPL2
@@ -20,9 +20,11 @@ pkgbase = stack-client
source = client-v2.6.4.tar.gz::https://github.com/nextcloud/client/archive/v2.6.4.tar.gz
source = http://mirror.transip.net/stack/software/source/stack-client-source-2.6.4.20200506.tar.gz
source = APPLICATION_NAME.patch
+ source = qt5.15_missing_qpainterpath_include.patch
sha256sums = aea4dff6bf2a6bd2b783a6175ac2393ffcae2949536b15def7aae4372f0c24ef
sha256sums = b6dc38ad1830b3b1b99863c853117bd03198bf0c15ecbe06da30b644c5c8f14d
sha256sums = 65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559
+ sha256sums = 449c798e17b9e6bea8ab0021383a9c97422e28bebae1db0166fab3f8971e4fc0
pkgname = stack-client
diff --git a/PKGBUILD b/PKGBUILD
index 074140623cd9..b89e3ed5806a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
pkgname=stack-client
pkgver=2.6.4
-pkgrel=1
+pkgrel=2
pkgdesc="The STACK Client provides file sync to desktop clients."
arch=('x86_64')
url='https://www.transip.nl/stack/'
@@ -11,13 +11,16 @@ makedepends=('cmake' 'qt5-tools' 'extra-cmake-modules' 'frameworkintegration')
conflicts=('stack-client-bin')
source=("client-v${pkgver}.tar.gz::https://github.com/nextcloud/client/archive/v${pkgver}.tar.gz"
"http://mirror.transip.net/stack/software/source/stack-client-source-${pkgver}.20200506.tar.gz"
- "APPLICATION_NAME.patch")
+ "APPLICATION_NAME.patch"
+ "qt5.15_missing_qpainterpath_include.patch")
sha256sums=('aea4dff6bf2a6bd2b783a6175ac2393ffcae2949536b15def7aae4372f0c24ef'
'b6dc38ad1830b3b1b99863c853117bd03198bf0c15ecbe06da30b644c5c8f14d'
- '65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559')
+ '65a37003112bbc07bb372693793ff5a2dba86199d0da845e7203096ecc33c559'
+ '449c798e17b9e6bea8ab0021383a9c97422e28bebae1db0166fab3f8971e4fc0')
prepare() {
patch -p1 < ${srcdir}/APPLICATION_NAME.patch
+ patch -p1 < ${srcdir}/qt5.15_missing_qpainterpath_include.patch
cd desktop-${pkgver}
for file in ${srcdir}/patches/*
diff --git a/qt5.15_missing_qpainterpath_include.patch b/qt5.15_missing_qpainterpath_include.patch
new file mode 100644
index 000000000000..5846f6241e16
--- /dev/null
+++ b/qt5.15_missing_qpainterpath_include.patch
@@ -0,0 +1,11 @@
+diff -upr desktop-2.6.4-orig/src/libsync/networkjobs.cpp desktop-2.6.4/src/libsync/networkjobs.cpp
+--- a/desktop-2.6.4/src/libsync/networkjobs.cpp 2020-06-20 21:00:43.636264023 +0200
++++ b/desktop-2.6.4/src/libsync/networkjobs.cpp 2020-06-20 21:01:01.126316908 +0200
+@@ -31,6 +31,7 @@
+ #include <QJsonDocument>
+ #include <QJsonObject>
+ #include <QPainter>
++#include <QPainterPath>
+
+ #include "networkjobs.h"
+ #include "account.h"