summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2017-07-03 20:07:10 +0200
committerSimon Reiser2017-07-03 20:07:10 +0200
commit1f185c37df074abab442eb44485c33edd2e41274 (patch)
treea1f7b8126efd407d22a8cf0a7f4e41bc7773698f
parentb75a89473cd895fe63a8a62a7500408fc61988e3 (diff)
downloadaur-1f185c37df074abab442eb44485c33edd2e41274.tar.gz
Added bash-completion support
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
-rw-r--r--stack.bash2
3 files changed, 12 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5154b30ad3b7..107c409d9e2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = stack-static
pkgdesc = The Haskell Tool Stack (linked statically)
pkgver = 1.4.0
- pkgrel = 1
+ pkgrel = 2
arch = x86_64
license = custom:BSD3
+ optdepends = bash-completion
provides = stack
conflicts = stack
conflicts = haskell-stack
replaces = stack
replaces = haskell-stack
+ source = stack.bash
source = https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-1.4.0-linux-x86_64-static.tar.gz
source = https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-1.4.0-linux-x86_64-static.tar.gz.asc
validpgpkeys = C5705533DA4F78D8664B5DC0575159689BEFB442
+ sha256sums = df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2
sha256sums = 8cc2bb0da1e5f77de7257662c63c82ed289b09a37c72c2fc7a8a81983dbe30ba
sha256sums = 65471f5165d5aa87cbe4bc32ce0e895481fa824211c44f24c107fb2ac58e9b7b
diff --git a/PKGBUILD b/PKGBUILD
index f57381dfa97e..8d0f3679dd2d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: <simonfxr@gmail.com>
pkgname=stack-static
pkgver=1.4.0
-pkgrel=1
+pkgrel=2
epoch=
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
@@ -10,11 +10,14 @@ license=('custom:BSD3')
provides=( stack )
conflicts=( stack haskell-stack )
replaces=( stack haskell-stack )
+optdepends=( bash-completion )
source=(
+ "stack.bash"
"https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-${pkgver}-linux-x86_64-static.tar.gz"
"https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-${pkgver}-linux-x86_64-static.tar.gz.asc"
)
sha256sums=(
+ 'df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2'
'8cc2bb0da1e5f77de7257662c63c82ed289b09a37c72c2fc7a8a81983dbe30ba'
'65471f5165d5aa87cbe4bc32ce0e895481fa824211c44f24c107fb2ac58e9b7b'
)
@@ -24,10 +27,11 @@ package() {
cd "${srcdir}"
local d="stack-${pkgver}-linux-x86_64-static"
- mkdir -p "${pkgdir}"/usr/{bin,share/{doc,licenses}/"${pkgname}"}
+ mkdir -p "${pkgdir}"/usr/{{bin,share/{doc,licenses}/"${pkgname}"},share/bash-completion/completions}
cp "${d}/stack" "${pkgdir}/usr/bin"
cp -R "${d}/doc/." "${pkgdir}/usr/share/doc/${pkgname}/"
cp "${d}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/"
+ cp "stack.bash" "${pkgdir}/usr/share/bash-completion/completions/stack"
}
# vim:set ts=2 sw=2 et:
diff --git a/stack.bash b/stack.bash
new file mode 100644
index 000000000000..eb6b2b56474d
--- /dev/null
+++ b/stack.bash
@@ -0,0 +1,2 @@
+
+eval "$(/usr/bin/stack --bash-completion-script stack)"