summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2018-04-29 19:17:40 +0200
committerSimon Reiser2018-04-29 19:17:40 +0200
commit8f44c509fe6023f5a5ce241b8d4ae3a69373eb08 (patch)
treec9444f078d39045c1d12044e4b8232d868fbffe6
parent2678d274f6e541465da9a9b7a5a4302cca3b8259 (diff)
downloadaur-8f44c509fe6023f5a5ce241b8d4ae3a69373eb08.tar.gz
v1.7.1
-rw-r--r--PKGBUILD23
1 files changed, 10 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72feae6bffa6..d45f04589f92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,29 @@
# Maintainer: <simonfxr@gmail.com>
pkgname=stack-static
-pkgver=1.6.5
+pkgver=1.7.1
pkgrel=1
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
curl="https://github.com/commercialhaskell/stack"
license=('custom:BSD3')
provides=( stack )
-conflicts=( stack haskell-stack )
-replaces=( stack haskell-stack )
-depends=( ncurses5-compat-libs ) # needed for working ghc downloaded by stack
+conflicts=( stack stack-bin haskell-stack )
+replaces=( stack stack-bin haskell-stack )
+depends=( gmp gcc-libs zlib ncurses5-compat-libs ) # needed for working ghc downloaded by stack
optdepends=( bash-completion )
source=(
"stack.bash"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64-static.tar.gz.asc"
-)
-sha256sums=(
- 'df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2'
- 'f8876fa73c4bb95c1d762073af2dfa4a003d795709ec3fee2f9743ca6a5fedc6'
- 'SKIP'
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz.asc"
)
+sha256sums=('df46833a748574d01f38d4120e5021ee6fac9b8a70995674ca0bd2cacbd3e3c2'
+ '647306bbf65dd0b555486e2a32776ba1cfe0c8f380e31c6aa93abd452cb209ee'
+ 'SKIP')
validpgpkeys=('C5705533DA4F78D8664B5DC0575159689BEFB442')
package() {
cd "${srcdir}"
-
- local d="stack-${pkgver}-linux-x86_64-static"
+ local d="stack-${pkgver}-linux-x86_64"
mkdir -p "${pkgdir}"/usr/{{bin,share/{doc,licenses}/"${pkgname}"},share/bash-completion/completions}
cp "${d}/stack" "${pkgdir}/usr/bin"
cp -R "${d}/doc/." "${pkgdir}/usr/share/doc/${pkgname}/"