summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2023-09-30 09:20:10 +0200
committerSimon Reiser2023-09-30 09:20:10 +0200
commitb355214bd56e2daa63a0696f52f287cb5d6e8f1a (patch)
treec5a1bcde565ec318b71d44eb615f807dcaf0499d
parent197b10e8b18345cb635f3b6c77a0a5470242723e (diff)
downloadaur-b355214bd56e2daa63a0696f52f287cb5d6e8f1a.tar.gz
v2.13.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8709fa12f7dd..cfb4eedfb866 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stack-static
pkgdesc = The Haskell Tool Stack (linked statically)
- pkgver = 2.11.1
+ pkgver = 2.13.1
pkgrel = 1
url = https://github.com/commercialhaskell/stack
arch = x86_64
@@ -10,17 +10,17 @@ pkgbase = stack-static
depends = zlib
optdepends = bash-completion
optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
- provides = stack=2.11.1
+ provides = stack=2.13.1
conflicts = stack
conflicts = stack-bin
conflicts = haskell-stack
replaces = stack
replaces = stack-bin
replaces = haskell-stack
- source = https://github.com/commercialhaskell/stack/releases/download/v2.11.1/stack-2.11.1-linux-x86_64-static.tar.gz
- source = https://github.com/commercialhaskell/stack/releases/download/v2.11.1/stack-2.11.1-linux-x86_64-static.tar.gz.asc
+ source = https://github.com/commercialhaskell/stack/releases/download/v2.13.1/stack-2.13.1-linux-x86_64.tar.gz
+ source = https://github.com/commercialhaskell/stack/releases/download/v2.13.1/stack-2.13.1-linux-x86_64.tar.gz.asc
validpgpkeys = C5705533DA4F78D8664B5DC0575159689BEFB442
- sha256sums = ebba4f236989d60332e6e20dc5f3d62a8e408e9f479ed6c6c594304fc239270a
+ sha256sums = 45281bb2385e928916ec8bcbc7ab790ce8721bbf805f3d0752544ada22ad5ea3
sha256sums = SKIP
pkgname = stack-static
diff --git a/PKGBUILD b/PKGBUILD
index 38f10983d569..369a5034bfb0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: <me@sfxr.de>
pkgname=stack-static
-_pkgver=2.11.1
+_pkgver=2.13.1
pkgver=${_pkgver}
pkgrel=1
_vpref=''
@@ -18,16 +18,16 @@ optdepends=(
"ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5"
)
source=(
- "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64-static.tar.gz"
- "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64-static.tar.gz.asc"
+ "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64.tar.gz.asc"
)
-sha256sums=('ebba4f236989d60332e6e20dc5f3d62a8e408e9f479ed6c6c594304fc239270a'
+sha256sums=('45281bb2385e928916ec8bcbc7ab790ce8721bbf805f3d0752544ada22ad5ea3'
'SKIP')
validpgpkeys=('C5705533DA4F78D8664B5DC0575159689BEFB442')
package() {
cd "${srcdir}"
- local d="stack-${_pkgver}-linux-x86_64-static"
+ local d="stack-${_pkgver}-linux-x86_64"
mkdir -p "${pkgdir}"/usr/{bin,share/{doc,licenses}/"${pkgname}"}
mkdir -p "${pkgdir}"/usr/share/{bash-completion/completions,fish/vendor_completions.d}
cp "${d}/stack" "${pkgdir}/usr/bin"