summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2017-06-30 08:02:40 +0200
committerSimon Reiser2017-06-30 08:02:40 +0200
commitb75a89473cd895fe63a8a62a7500408fc61988e3 (patch)
treed9538ed45a2e6263b546d4155ca7d8bca53a334d
downloadaur-b75a89473cd895fe63a8a62a7500408fc61988e3.tar.gz
Initial PKGBUILD
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5154b30ad3b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = stack-static
+ pkgdesc = The Haskell Tool Stack (linked statically)
+ pkgver = 1.4.0
+ pkgrel = 1
+ arch = x86_64
+ license = custom:BSD3
+ provides = stack
+ conflicts = stack
+ conflicts = haskell-stack
+ replaces = stack
+ replaces = haskell-stack
+ source = https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-1.4.0-linux-x86_64-static.tar.gz
+ source = https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-1.4.0-linux-x86_64-static.tar.gz.asc
+ validpgpkeys = C5705533DA4F78D8664B5DC0575159689BEFB442
+ sha256sums = 8cc2bb0da1e5f77de7257662c63c82ed289b09a37c72c2fc7a8a81983dbe30ba
+ sha256sums = 65471f5165d5aa87cbe4bc32ce0e895481fa824211c44f24c107fb2ac58e9b7b
+
+pkgname = stack-static
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f57381dfa97e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: <simonfxr@gmail.com>
+pkgname=stack-static
+pkgver=1.4.0
+pkgrel=1
+epoch=
+pkgdesc="The Haskell Tool Stack (linked statically)"
+arch=('x86_64')
+curl="https://github.com/commercialhaskell/stack"
+license=('custom:BSD3')
+provides=( stack )
+conflicts=( stack haskell-stack )
+replaces=( stack haskell-stack )
+source=(
+ "https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-${pkgver}-linux-x86_64-static.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/v1.4.0/stack-${pkgver}-linux-x86_64-static.tar.gz.asc"
+)
+sha256sums=(
+ '8cc2bb0da1e5f77de7257662c63c82ed289b09a37c72c2fc7a8a81983dbe30ba'
+ '65471f5165d5aa87cbe4bc32ce0e895481fa824211c44f24c107fb2ac58e9b7b'
+)
+validpgpkeys=('C5705533DA4F78D8664B5DC0575159689BEFB442')
+
+package() {
+ cd "${srcdir}"
+
+ local d="stack-${pkgver}-linux-x86_64-static"
+ mkdir -p "${pkgdir}"/usr/{bin,share/{doc,licenses}/"${pkgname}"}
+ cp "${d}/stack" "${pkgdir}/usr/bin"
+ cp -R "${d}/doc/." "${pkgdir}/usr/share/doc/${pkgname}/"
+ cp "${d}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/"
+}
+
+# vim:set ts=2 sw=2 et: