summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Reiser2022-09-19 18:26:34 +0200
committerSimon Reiser2022-09-19 18:26:34 +0200
commitf61fc7fb76ef9b36296ebb79bb7a486f95e54765 (patch)
tree9d263abffa3e7405bc691a5beb07775fc8a47ba6
parent68c14b4a0e421e072d8b670484729eaa9b9fe7c1 (diff)
downloadaur-f61fc7fb76ef9b36296ebb79bb7a486f95e54765.tar.gz
v2.9.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdba5c7d3ad1..6e35012c091e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stack-static
pkgdesc = The Haskell Tool Stack (linked statically)
- pkgver = 2.7.5
+ pkgver = 2.9.1
pkgrel = 1
url = https://github.com/commercialhaskell/stack
arch = x86_64
@@ -10,17 +10,17 @@ pkgbase = stack-static
depends = zlib
optdepends = bash-completion
optdepends = ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5
- provides = stack=2.7.5
+ provides = stack=2.9.1
conflicts = stack
conflicts = stack-bin
conflicts = haskell-stack
replaces = stack
replaces = stack-bin
replaces = haskell-stack
- source = https://github.com/commercialhaskell/stack/releases/download/v2.7.5/stack-2.7.5-linux-x86_64.tar.gz
- source = https://github.com/commercialhaskell/stack/releases/download/v2.7.5/stack-2.7.5-linux-x86_64.tar.gz.asc
+ source = https://github.com/commercialhaskell/stack/releases/download/v2.9.1/stack-2.9.1-linux-x86_64-static.tar.gz
+ source = https://github.com/commercialhaskell/stack/releases/download/v2.9.1/stack-2.9.1-linux-x86_64-static.tar.gz.asc
validpgpkeys = C5705533DA4F78D8664B5DC0575159689BEFB442
- sha256sums = 9bcd165358d4dcafd2b33320d4fe98ce72faaf62300cc9b0fb86a27eb670da50
+ sha256sums = cd8ef4a844f141159189899a128a33f4beb9ec4e66ac96fc2ada47a626a9d462
sha256sums = SKIP
pkgname = stack-static
diff --git a/PKGBUILD b/PKGBUILD
index 6dd55a73b0c0..01bb8d7988bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,10 @@
# Maintainer: <me@sfxr.de>
pkgname=stack-static
-pkgver=2.7.5
+_pkgver=2.9.1
+pkgver=${_pkgver}
pkgrel=1
+_vpref=''
pkgdesc="The Haskell Tool Stack (linked statically)"
arch=('x86_64')
url="https://github.com/commercialhaskell/stack"
@@ -16,16 +18,16 @@ optdepends=(
"ncurses5-compat-libs: using older ghc's linking against libtinfo.so.5"
)
source=(
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz"
- "https://github.com/commercialhaskell/stack/releases/download/v${pkgver}/stack-${pkgver}-linux-x86_64.tar.gz.asc"
+ "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64-static.tar.gz"
+ "https://github.com/commercialhaskell/stack/releases/download/${_vpref}v${_pkgver}/stack-${_pkgver}-linux-x86_64-static.tar.gz.asc"
)
-sha256sums=('9bcd165358d4dcafd2b33320d4fe98ce72faaf62300cc9b0fb86a27eb670da50'
+sha256sums=('cd8ef4a844f141159189899a128a33f4beb9ec4e66ac96fc2ada47a626a9d462'
'SKIP')
validpgpkeys=('C5705533DA4F78D8664B5DC0575159689BEFB442')
package() {
cd "${srcdir}"
- local d="stack-${pkgver}-linux-x86_64"
+ local d="stack-${_pkgver}-linux-x86_64-static"
mkdir -p "${pkgdir}"/usr/{bin,share/{doc,licenses}/"${pkgname}"}
mkdir -p "${pkgdir}"/usr/share/{bash-completion/completions,fish/vendor_completions.d}
cp "${d}/stack" "${pkgdir}/usr/bin"