summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLars Francke2022-10-21 16:09:17 +0200
committerLars Francke2022-10-21 16:09:17 +0200
commitc733af934598ff78a765164a659015e1e47a4a76 (patch)
tree4200f10e7b44ad98140cb0be0eb9ed708df4324c
downloadaur-c733af934598ff78a765164a659015e1e47a4a76.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2c9e250703b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stackablectl
+ pkgdesc = Command line tool to interact with a Stackable Data Platform
+ pkgver = v0.5.0.r10.g53df183
+ pkgrel = 1
+ url = https://github.com/stackabletech/stackablectl/
+ arch = x86_64
+ license = Apache
+ makedepends = go
+ makedepends = rust
+ source = stackablectl::git+https://github.com/stackabletech/stackablectl.git
+ b2sums = SKIP
+
+pkgname = stackablectl
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c6a9b954b0ed
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*
+
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b7e27398092
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Lars Francke <lars.francke@stackable.tech>
+
+pkgname=stackablectl
+pkgver=v0.5.0.r10.g53df183
+pkgrel=1
+pkgdesc="Command line tool to interact with a Stackable Data Platform"
+arch=('x86_64')
+url="https://github.com/stackabletech/stackablectl/"
+license=('Apache')
+makedepends=('go' 'rust')
+source=("$pkgname::git+https://github.com/stackabletech/stackablectl.git")
+b2sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd "$pkgname"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname"
+ cargo build --frozen --release --all-features
+}
+
+check() {
+ cd "$pkgname"
+ cargo test --frozen --all-features
+}
+
+package() {
+ cd "$pkgname"
+ install -vDm755 -t "$pkgdir/usr/bin" target/release/stackablectl
+}