summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-25 11:14:24 +0800
committerzxp198210052024-01-25 11:14:24 +0800
commit570a2572eae6a1f863f676391b4dbd444f34101e (patch)
tree05eb1665cf4bd8a27d00d39d8b05ba488b512b28
parentdf57d7c61da5353163e8d1d032437e60c23084f6 (diff)
downloadaur-570a2572eae6a1f863f676391b4dbd444f34101e.tar.gz
fix errors
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD15
-rw-r--r--stackzy.sh5
3 files changed, 14 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60094235cc1b..5bc8e4fdbbda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,21 @@
pkgbase = stackzy-bin
pkgdesc = A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop
pkgver = 1.2.6
- pkgrel = 4
+ pkgrel = 5
url = https://github.com/theapache64/stackzy
arch = x86_64
- license = Apache
- depends = libxtst
- depends = libglvnd
- depends = fontconfig
+ license = Apache-2.0
depends = java-runtime
depends = libxrender
depends = alsa-lib
depends = libxi
- depends = libxext
- depends = libx11
+ depends = libxtst
+ depends = libglvnd
+ depends = fontconfig
provides = stackzy=1.2.6
source = stackzy-1.2.6.deb::https://github.com/theapache64/stackzy/releases/download/1.2.6/stackzy_1.2.6-1_amd64.deb
source = stackzy.sh
sha256sums = be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb
- sha256sums = 33fcb3bd63d952033644afe53eaf5c94d877743d6fe848b23136c9fa0fbf8a19
+ sha256sums = 1c7af4eb5a50f4e51c506b62b6600af8bdb5574e3e16fba5be2fdad958ec0e05
pkgname = stackzy-bin
diff --git a/PKGBUILD b/PKGBUILD
index f456a1cdc8e9..7ddc64d5ffbd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,28 @@
pkgname=stackzy-bin
_pkgname=Stackzy
pkgver=1.2.6
-pkgrel=4
+pkgrel=5
pkgdesc="A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop"
arch=('x86_64')
url="https://github.com/theapache64/stackzy"
-license=("Apache")
+license=("Apache-2.0")
provides=("${pkgname%-bin}=${pkgver}")
confilcts=("${pkgname%-bin}")
depends=(
- 'libxtst'
- 'libglvnd'
- 'fontconfig'
'java-runtime'
'libxrender'
'alsa-lib'
'libxi'
- 'libxext'
- 'libx11'
+ 'libxtst'
+ 'libglvnd'
+ 'fontconfig'
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}-1_amd64.deb"
"${pkgname%-bin}.sh"
)
sha256sums=('be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb'
- '33fcb3bd63d952033644afe53eaf5c94d877743d6fe848b23136c9fa0fbf8a19')
+ '1c7af4eb5a50f4e51c506b62b6600af8bdb5574e3e16fba5be2fdad958ec0e05')
build() {
sed -e "s|@appname@|${pkgname%-bin}|g" \
-e "s|@runname@|${_pkgname}|g" \
@@ -41,5 +39,4 @@ package() {
cp -r "${srcdir}/opt" "${pkgdir}"
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
- install -Dm644 "${srcdir}/opt/${pkgname%-bin}/share/doc/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/stackzy.sh b/stackzy.sh
index 118d2f3ba387..4f3b2d4f4162 100644
--- a/stackzy.sh
+++ b/stackzy.sh
@@ -1,9 +1,8 @@
#!/bin/sh
set -e
_APPDIR="/opt/@appname@"
-_RUNAPP="${_APPDIR}/bin/@runname@"
+_RUNNAME="${_APPDIR}/bin/@runname@"
export PATH="${_APPDIR}/bin:${PATH}"
export LD_LIBRARY_PATH="${_APPDIR}/lib:${_APPDIR}/lib/runtime/lib:${LD_LIBRARY_PATH}"
cd "${_APPDIR}"
-exec "${_RUNAPP}" "$@"
-exit \ No newline at end of file
+exec "${_RUNAPP}" "$@" || exit $? \ No newline at end of file