summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-03-13 16:35:36 +0800
committerzxp198210052023-03-13 16:35:36 +0800
commit94395068fdd94c3cf190d8319694e862e9895e38 (patch)
tree91bbec172d3b4b4027df7aa2c0424bc546c410a1
downloadaur-94395068fdd94c3cf190d8319694e862e9895e38.tar.gz
first release
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..609b9ad9628d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = stackzy-bin
+ pkgdesc = A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop
+ pkgver = 1.2.5
+ pkgrel = 1
+ url = https://github.com/theapache64/stackzy
+ arch = x86_64
+ license = Apache2
+ depends = libxtst
+ depends = libglvnd
+ depends = fontconfig
+ depends = libnet
+ depends = java-runtime
+ depends = libxrender
+ depends = alsa-lib
+ depends = hicolor-icon-theme
+ source = stackzy-1.2.5.deb::https://github.com/theapache64/stackzy/releases/download/1.2.5/stackzy_1.2.5-1_amd64.deb
+ sha256sums = 26c3727c54db393ca6a6debe72e42551c26f4a850167549159824d9e74d5e59f
+
+pkgname = stackzy-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..62eb9016e46f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+pkgname=stackzy-bin
+_pkgname=stackzy
+pkgver=1.2.5
+pkgrel=1
+pkgdesc="A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop"
+arch=('x86_64')
+url="https://github.com/theapache64/stackzy"
+license=('Apache2')
+providers=(theapache64)
+options=()
+depends=(libxtst libglvnd fontconfig libnet java-runtime libxrender alsa-lib hicolor-icon-theme)
+source=("${_pkgname}-${pkgver}.deb::${url}/releases/download/${pkgver}/${_pkgname}_${pkgver}-1_amd64.deb")
+sha256sums=('26c3727c54db393ca6a6debe72e42551c26f4a850167549159824d9e74d5e59f')
+package() {
+ bsdtar -xf data.tar.xz -C "${pkgdir}"
+ sed 's/Icon=\/opt\/stackzy\/lib\/Stackzy.png/Icon=stackzy/g;s/Unknown/Utility;Development;/g' -i "${pkgdir}/opt/${_pkgname}/lib/${_pkgname}-Stackzy.desktop"
+ install -Dm644 "${pkgdir}/opt/${_pkgname}/lib/${_pkgname}-Stackzy.desktop" "${pkgdir}/usr/share/applications/${_pkgname}.desktop"
+ install -Dm644 "${pkgdir}/opt/${_pkgname}/lib/Stackzy.png" "${pkgdir}/usr/share/icons/hicolor/scalable/apps/${_pkgname}.png"
+}