summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-11-13 16:24:53 +0800
committerzxp198210052023-11-13 16:24:53 +0800
commitb69f865fe72c37e5d1977eb500104f3c14590ac3 (patch)
treeb4242b37d6ad1fab5e15356c257e2bf5e376b4dc
parent459398099ecb6b282a989129dc7cd30ab4153618 (diff)
downloadaur-b69f865fe72c37e5d1977eb500104f3c14590ac3.tar.gz
fix errors
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11654f3efdf..33f55364853e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stackzy-bin
pkgdesc = A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop
pkgver = 1.2.6
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/theapache64/stackzy
arch = x86_64
license = Apache
@@ -11,11 +11,9 @@ pkgbase = stackzy-bin
depends = java-runtime
depends = libxrender
depends = alsa-lib
- depends = glibc
depends = libxi
depends = libxext
depends = libx11
- depends = zlib
provides = stackzy=1.2.6
source = stackzy-1.2.6.deb::https://github.com/theapache64/stackzy/releases/download/1.2.6/stackzy_1.2.6-1_amd64.deb
source = LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/1.2.6/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 5210a5eed733..e69cc37c5164 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,35 @@
pkgname=stackzy-bin
_pkgname=Stackzy
pkgver=1.2.6
-pkgrel=2
+pkgrel=3
pkgdesc="A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop"
arch=('x86_64')
url="https://github.com/theapache64/stackzy"
license=("Apache")
provides=("${pkgname%-bin}=${pkgver}")
confilcts=("${pkgname%-bin}")
-depends=('libxtst' 'libglvnd' 'fontconfig' 'java-runtime' 'libxrender' 'alsa-lib' 'glibc' 'libxi' 'libxext' 'libx11' 'zlib')
-source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}-1_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/${pkgver}/LICENSE")
+depends=(
+ 'libxtst'
+ 'libglvnd'
+ 'fontconfig'
+ 'java-runtime'
+ 'libxrender'
+ 'alsa-lib'
+ 'libxi'
+ 'libxext'
+ 'libx11'
+)
+source=(
+ "${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}-1_amd64.deb"
+ "LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/${pkgver}/LICENSE"
+)
sha256sums=('be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb'
'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
-prepare() {
+build() {
bsdtar -xf "${srcdir}/data.tar.zst"
- rm -rf "${srcdir}/opt/${pkgname%-bin}/lib/app/resources"
- sed "s|/opt/${pkgname%-bin}/bin/${_pkgname}|${pkgname%-bin}|g;s|/opt/${pkgname%-bin}/lib/${_pkgname}.png|${pkgname%-bin}|g;s|Unknown|Utility;Development;|g" \
+ sed -e "s|/opt/${pkgname%-bin}/bin/${_pkgname}|${pkgname%-bin}|g" \
+ -e "s|/opt/${pkgname%-bin}/lib/${_pkgname}.png|${pkgname%-bin}|g" \
+ -e "s|Unknown|Utility;Development;|g" \
-i "${srcdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_pkgname}.desktop"
}
package() {