summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-12-20 15:57:27 +0800
committerzxp198210052023-12-20 15:57:27 +0800
commitdf57d7c61da5353163e8d1d032437e60c23084f6 (patch)
treebcba1ab92cdcac226165ccad970c5324827335a0
parentb69f865fe72c37e5d1977eb500104f3c14590ac3 (diff)
downloadaur-df57d7c61da5353163e8d1d032437e60c23084f6.tar.gz
fix errors
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD16
-rw-r--r--stackzy.sh9
3 files changed, 21 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 33f55364853e..60094235cc1b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stackzy-bin
pkgdesc = A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop
pkgver = 1.2.6
- pkgrel = 3
+ pkgrel = 4
url = https://github.com/theapache64/stackzy
arch = x86_64
license = Apache
@@ -16,8 +16,8 @@ pkgbase = stackzy-bin
depends = libx11
provides = stackzy=1.2.6
source = stackzy-1.2.6.deb::https://github.com/theapache64/stackzy/releases/download/1.2.6/stackzy_1.2.6-1_amd64.deb
- source = LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/1.2.6/LICENSE
+ source = stackzy.sh
sha256sums = be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb
- sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
+ sha256sums = 33fcb3bd63d952033644afe53eaf5c94d877743d6fe848b23136c9fa0fbf8a19
pkgname = stackzy-bin
diff --git a/PKGBUILD b/PKGBUILD
index e69cc37c5164..f456a1cdc8e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=stackzy-bin
_pkgname=Stackzy
pkgver=1.2.6
-pkgrel=3
+pkgrel=4
pkgdesc="A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop"
arch=('x86_64')
url="https://github.com/theapache64/stackzy"
@@ -22,11 +22,14 @@ depends=(
)
source=(
"${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}-1_amd64.deb"
- "LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/${pkgver}/LICENSE"
+ "${pkgname%-bin}.sh"
)
sha256sums=('be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb'
- 'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
+ '33fcb3bd63d952033644afe53eaf5c94d877743d6fe848b23136c9fa0fbf8a19')
build() {
+ sed -e "s|@appname@|${pkgname%-bin}|g" \
+ -e "s|@runname@|${_pkgname}|g" \
+ -i "${srcdir}/${pkgname%-bin}.sh"
bsdtar -xf "${srcdir}/data.tar.zst"
sed -e "s|/opt/${pkgname%-bin}/bin/${_pkgname}|${pkgname%-bin}|g" \
-e "s|/opt/${pkgname%-bin}/lib/${_pkgname}.png|${pkgname%-bin}|g" \
@@ -34,10 +37,9 @@ build() {
-i "${srcdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_pkgname}.desktop"
}
package() {
- install -Dm755 -d "${pkgdir}/"{opt,usr/bin}
- cp -r "${srcdir}/opt/${pkgname%-bin}" "${pkgdir}/opt"
- ln -sf "/opt/${pkgname%-bin}/${_pkgname}" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ install -Dm755 "${srcdir}/${pkgname%-bin}.sh" "${pkgdir}/usr/bin/${pkgname%-bin}"
+ cp -r "${srcdir}/opt" "${pkgdir}"
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
install -Dm644 "${srcdir}/opt/${pkgname%-bin}/lib/${_pkgname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
- install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -Dm644 "${srcdir}/opt/${pkgname%-bin}/share/doc/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
} \ No newline at end of file
diff --git a/stackzy.sh b/stackzy.sh
new file mode 100644
index 000000000000..118d2f3ba387
--- /dev/null
+++ b/stackzy.sh
@@ -0,0 +1,9 @@
+#!/bin/sh
+set -e
+_APPDIR="/opt/@appname@"
+_RUNAPP="${_APPDIR}/bin/@runname@"
+export PATH="${_APPDIR}/bin:${PATH}"
+export LD_LIBRARY_PATH="${_APPDIR}/lib:${_APPDIR}/lib/runtime/lib:${LD_LIBRARY_PATH}"
+cd "${_APPDIR}"
+exec "${_RUNAPP}" "$@"
+exit \ No newline at end of file