summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052023-08-11 13:54:19 +0800
committerzxp198210052023-08-11 13:54:19 +0800
commitf51c797e61c917ce31779ca848c73b4cb68e7084 (patch)
tree4c486e7509438f006d88ac2198e149f4078c5454
parent2fe7974efc4ca218dbbb9019052aeee6ab047042 (diff)
downloadaur-f51c797e61c917ce31779ca848c73b4cb68e7084.tar.gz
update to 1.2.6
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 21 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a11e499aac2e..00bad515eea3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = stackzy-bin
pkgdesc = A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop
- pkgver = 1.2.5
- pkgrel = 3
+ pkgver = 1.2.6
+ pkgrel = 1
url = https://github.com/theapache64/stackzy
arch = x86_64
- license = custom
+ license = Apache
depends = libxtst
depends = libglvnd
depends = fontconfig
@@ -16,10 +16,10 @@ pkgbase = stackzy-bin
depends = libxext
depends = libx11
depends = zlib
- options = !strip
- source = stackzy-1.2.5.deb::https://github.com/theapache64/stackzy/releases/download/1.2.5/stackzy_1.2.5-1_amd64.deb
- source = LICENSE::https://github.com/theapache64/stackzy/raw/master/LICENSE
- sha256sums = 26c3727c54db393ca6a6debe72e42551c26f4a850167549159824d9e74d5e59f
+ provides = stackzy=1.2.6
+ source = stackzy-1.2.6.deb::https://github.com/theapache64/stackzy/releases/download/1.2.6/stackzy_1.2.6-1_amd64.deb
+ source = LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/master/LICENSE
+ sha256sums = be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb
sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
pkgname = stackzy-bin
diff --git a/PKGBUILD b/PKGBUILD
index d958fd63112f..73c63903ad50 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,24 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
-pkgname="stackzy-bin"
-pkgver=1.2.5
-pkgrel=3
+pkgname=stackzy-bin
+_appname=Stackzy
+pkgver=1.2.6
+pkgrel=1
pkgdesc="A cross-platform desktop application to identify libraries used inside an android application. Made possible by Compose Desktop"
arch=('x86_64')
url="https://github.com/theapache64/stackzy"
-license=(custom)
-providers=()
-confilts=("${pkgname%-bin}")
+license=("Apache")
+provides=("${pkgname%-bin}=${pkgver}")
+confilcts=("${pkgname%-bin}")
depends=('libxtst' 'libglvnd' 'fontconfig' 'java-runtime' 'libxrender' 'alsa-lib' 'glibc' 'libxi' 'libxext' 'libx11' 'zlib')
-options=(!strip)
source=("${pkgname%-bin}-${pkgver}.deb::${url}/releases/download/${pkgver}/${pkgname%-bin}_${pkgver}-1_amd64.deb"
- "LICENSE::${url}/raw/master/LICENSE")
-sha256sums=('26c3727c54db393ca6a6debe72e42551c26f4a850167549159824d9e74d5e59f'
+ "LICENSE::https://raw.githubusercontent.com/theapache64/stackzy/master/LICENSE")
+sha256sums=('be46f24ab891c1c3007715ceb539b006f281d445743ab77195c7c6f47cafbdeb'
'c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
package() {
- bsdtar -xf data.tar.xz -C "${pkgdir}"
- sed 's|Icon=/opt/stackzy/lib/Stackzy.png|Icon=stackzy|g;s|Unknown|Utility;Development;|g' -i "${pkgdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-Stackzy.desktop"
- install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-Stackzy.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
- install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/lib/Stackzy.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
+ bsdtar -xf "${srcdir}/data.tar.zst" -C "${pkgdir}"
+ sed "s|/opt/${pkgname%-bin}/lib/${_appname}.png|${pkgname%-bin}|g;s|Unknown|Utility;Development;|g" \
+ -i "${pkgdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_appname}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/lib/${pkgname%-bin}-${_appname}.desktop" "${pkgdir}/usr/share/applications/${pkgname%-bin}.desktop"
+ install -Dm644 "${pkgdir}/opt/${pkgname%-bin}/lib/${_appname}.png" "${pkgdir}/usr/share/pixmaps/${pkgname%-bin}.png"
install -Dm644 "${srcdir}/LICENSE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
} \ No newline at end of file