summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMadison Lynch2023-06-12 22:03:09 -0700
committerMadison Lynch2023-06-12 22:03:09 -0700
commitd643ad231c84669fb2852b067fd14d100e1e7067 (patch)
tree6e610efcf3d23d3bec3201b8bd4feec403c57205
downloadaur-d643ad231c84669fb2852b067fd14d100e1e7067.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..87db5fd9ce56
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = stagenda
+ pkgdesc = A simple command-line agenda written in C
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/mxdixyz/stagenda
+ arch = x86_64
+ license = MIT
+ makedepends = gcc
+ makedepends = git
+ depends = glibc
+ source = stagenda-1.tar.gz::https://github.com/mxdixyz/stagenda/archive/refs/tags/1.tar.gz
+ md5sums = SKIP
+
+pkgname = stagenda
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed7acaee5329
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Madison Lynch <madi@mxdi.xyz>
+pkgname='stagenda'
+pkgver=1
+pkgrel=1
+pkgdesc="A simple command-line agenda written in C"
+arch=('x86_64')
+url="https://github.com/mxdixyz/stagenda"
+license=('MIT')
+depends=('glibc')
+makedepends=('gcc' 'git')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/mxdixyz/stagenda/archive/refs/tags/${pkgver}.tar.gz")
+md5sums=('SKIP')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make
+ install -Dm755 "./stagenda" "$pkgdir/usr/bin/stagenda"
+ install -Dm644 "./stagenda.1" "$pkgdir/usr/share/man/man1/stagenda.1"
+} \ No newline at end of file