summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-07-20 07:55:29 +0300
committerDimitris Kiziridis2020-07-20 07:55:29 +0300
commitb0216b93c0fbff744b2774e631f017177be59a61 (patch)
treef982be86df257316cb6426fbbb66b2be57b6585d
downloadaur-b0216b93c0fbff744b2774e631f017177be59a61.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD37
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2091ffa3a432
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = stakkr
+ pkgdesc = A recompose tool that uses docker compose to easily create / maintain a stack of services. Via a configuration file you can setup the required services and let the app link and start everything for you
+ pkgver = 4.2
+ pkgrel = 1
+ url = https://github.com/stakkr-org/stakkr
+ arch = any
+ license = Apache
+ makedepends = python-setuptools
+ depends = docker-compose
+ depends = python-click-plugins
+ depends = python-clint
+ depends = python-yaml
+ depends = python-anyconfig
+ depends = python-gitpython
+ conflicts = stakkr-git
+ source = stakkr-4.2.tar.gz::https://github.com/stakkr-org/stakkr/archive/v4.2.tar.gz
+ sha256sums = 2c3c75a476a533f8d9eab9901cedb1f1c3dc51fe9b3af2ce7ec410342bb2319d
+
+pkgname = stakkr
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..755a90c200ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=stakkr
+pkgver=4.2
+pkgrel=1
+pkgdesc='A recompose tool that uses docker compose to easily create / maintain a stack of services. Via a configuration file you can setup the required services and let the app link and start everything for you'
+arch=('any')
+url='https://github.com/stakkr-org/stakkr'
+license=('Apache')
+conflicts=('stakkr-git')
+depends=('docker-compose'
+ 'python-click-plugins'
+ 'python-clint'
+ 'python-yaml'
+ 'python-anyconfig'
+ 'python-gitpython')
+makedepends=('python-setuptools')
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/stakkr-org/stakkr/archive/v${pkgver}.tar.gz")
+sha256sums=('2c3c75a476a533f8d9eab9901cedb1f1c3dc51fe9b3af2ce7ec410342bb2319d')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ for i in 35 36 37 38 39 40; do
+ sed -i "${i}s|==|>=|" setup.py
+ done
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file