summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOmri Bornstein2022-07-11 04:32:56 +0000
committerOmri Bornstein2022-07-11 04:32:56 +0000
commit77fd63b367b56bf9078f1261ab1662d30560c6a4 (patch)
treeb01dee0089b5439a06215cf8c4a26178e690584f
downloadaur-77fd63b367b56bf9078f1261ab1662d30560c6a4.tar.gz
Update to v1.0.2
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50c269ee6155
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = stalk-bin
+ pkgdesc = Cross-platform file watcher.
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://github.com/AppleGamer22/stalk
+ license = GPL3
+ optdepends = bash
+ optdepends = fish
+ optdepends = zsh
+ depends = dbus
+ conflicts = stalk
+ provides = stalk
+ arch = aarch64
+ source_aarch64 = https://github.com/AppleGamer22/stalk/releases/download/v1.0.2/stalk_1.0.2_linux_arm64.tar.gz
+ sha256sums_aarch64 = dc7761683610b7630b8401ebfd8f67857feb73a00acbc1803350c8c5b50911a7
+ arch = x86_64
+ source_x86_64 = https://github.com/AppleGamer22/stalk/releases/download/v1.0.2/stalk_1.0.2_linux_amd64.tar.gz
+ sha256sums_x86_64 = da2299b34b12b70a267c5d0cf7bd704d77083636867eded07c36c41fdc77f19a
+
+pkgname = stalk-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..966d2098b87f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# This file was generated by GoReleaser. DO NOT EDIT.
+# Maintainer: Omri Bornstein <omribor@gmail.com>
+# Contributor: Omri Bornstein <omribor@gmail.com>
+
+pkgname='stalk-bin'
+pkgver=1.0.2
+pkgrel=1
+pkgdesc='Cross-platform file watcher.'
+url='https://github.com/AppleGamer22/stalk'
+arch=('aarch64' 'x86_64')
+license=('GPL3')
+provides=('stalk')
+conflicts=('stalk')
+depends=('dbus')
+optdepends=('bash' 'fish' 'zsh')
+
+source_aarch64=("${pkgname}_${pkgver}_aarch64.tar.gz::https://github.com/AppleGamer22/stalk/releases/download/v1.0.2/stalk_1.0.2_linux_arm64.tar.gz")
+sha256sums_aarch64=('dc7761683610b7630b8401ebfd8f67857feb73a00acbc1803350c8c5b50911a7')
+
+source_x86_64=("${pkgname}_${pkgver}_x86_64.tar.gz::https://github.com/AppleGamer22/stalk/releases/download/v1.0.2/stalk_1.0.2_linux_amd64.tar.gz")
+sha256sums_x86_64=('da2299b34b12b70a267c5d0cf7bd704d77083636867eded07c36c41fdc77f19a')
+
+package() {
+ install -Dm755 stalk "${pkgdir}/usr/bin/stalk"
+ install -Dm644 stalk.1 "${pkgdir}/usr/share/man/man1/stalk.1"
+ install -Dm644 stalk.bash "${pkgdir}/usr/share/bash-completion/completions/stalk"
+ install -Dm644 stalk.fish "${pkgdir}/usr/share/fish/vendor_completions.d/stalk.fish"
+ install -Dm644 stalk.zsh "${pkgdir}/usr/share/zsh/site-functions/_stalk"
+
+}