summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabio Zanini2015-06-18 12:08:03 +0200
committerFabio Zanini2015-06-18 12:08:03 +0200
commit45042d20e7ea1c686aa86cdd91fc5aa6e1adeae3 (patch)
tree8120ea90f3c29cf2d7b8627ed22886a56af3bf39
downloadaur-45042d20e7ea1c686aa86cdd91fc5aa6e1adeae3.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1ed34127e17f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = stampy
+ pkgdesc = Mapper of short reads from illumina sequencing machines onto a reference genome
+ pkgver = 1.0.23
+ pkgrel = 1
+ url = http://www.well.ox.ac.uk/project-stampy
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = gcc
+ depends = python2
+ source = http://www.well.ox.ac.uk/bioinformatics/Software/Stampy-latest.tgz
+ md5sums = 30bbfc2c4a2750f6cc87bbfe52394dcd
+
+pkgname = stampy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e0a14bb6f67
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Fabio Zanini <fabio.zanini@tuebingen.mpg.de>
+pkgname=stampy
+pkgver=1.0.23
+pkgrel=1
+pkgdesc="Mapper of short reads from illumina sequencing machines onto a reference genome"
+arch=('i686' 'x86_64')
+url="http://www.well.ox.ac.uk/project-stampy"
+license=('custom')
+depends=('python2')
+makedepends=('gcc')
+source=(http://www.well.ox.ac.uk/bioinformatics/Software/Stampy-latest.tgz)
+md5sums=('30bbfc2c4a2750f6cc87bbfe52394dcd')
+
+build() {
+ echo $srcdir
+ cd "$srcdir/$pkgname-$pkgver"
+ # Python2 fix
+ sed -i 's/python?=python/python?=python2/' makefile
+
+ # g++ obsolete option fix
+ sed -i 's/-Wl /-Wall /' makefile
+
+ make
+
+ sed -i 's|#!/usr/bin/env python|#!/usr/bin/env python2|' stampy.py
+ # FIXME: Substitute all TABS by spaces
+ sed -i 's/ / /g' stampy.py
+
+}
+
+package() {
+ # Install manually
+ mkdir -p "$pkgdir/opt" "$pkgdir/usr/bin" "$pkgdir/usr/share/licenses/stampy"
+ cp -r "$srcdir/$pkgname-$pkgver" "$pkgdir/opt"
+ ln -s "$pkgdir/opt/$pkgname-$pkgver/stampy.py" "$pkgdir/usr/bin/stampy"
+
+ # Install license
+ sed -n '/This is a release version/,/support./p' "$srcdir/$pkgname-$pkgver/README.txt" > "$pkgdir/usr/share/licenses/stampy/LICENSE"
+}