summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgameslayer2022-12-05 01:32:22 +1000
committergameslayer2022-12-05 01:32:22 +1000
commitd3660d5327cd34e4f1b20d5ebaea257ab7a79102 (patch)
treee7c8455145f4a7ed9966fc6fe8d20ba0c2ae08ca
downloadaur-d3660d5327cd34e4f1b20d5ebaea257ab7a79102.tar.gz
This will be replacing stan-bin and will dramatically shrink the size of the package and stop the duplication and bloat of dependencies
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ccc93dbc0e79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = stan
+ pkgdesc = Unnofficial Stan desktop application
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://gitlab.com/Stan-desktop/application
+ arch = x86_64
+ license = GPL
+ makedepends = unzip
+ depends = libelectron
+ depends = nss
+ depends = gtk3
+ depends = libxss
+ depends = git
+ conflicts = Stan-bin
+ source = https://gitlab.com/Stan-desktop/application/-/archive/1.0.2-1/application-1.0.2-1.tar.bz2
+ sha256sums = 1652ba34a5ffc1bb7aa2e1587cbb9422056ba1d7813bac2d3af2e379fd2d4839
+
+pkgname = stan
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4a81f3c3f56
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=stan
+_pkgname=Stan
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Unnofficial Stan desktop application"
+arch=('x86_64')
+url="https://gitlab.com/Stan-desktop/application"
+license=('GPL')
+depends=('libelectron' 'nss' 'gtk3' 'libxss' 'git')
+makedepends=('unzip')
+conflicts=("Stan-bin")
+source=("https://gitlab.com/Stan-desktop/application/-/archive/$pkgver-$pkgrel/application-$pkgver-$pkgrel.tar.bz2")
+sha256sums=('1652ba34a5ffc1bb7aa2e1587cbb9422056ba1d7813bac2d3af2e379fd2d4839')
+
+package() {
+ for dir in application-$pkgver-$pkgrel ; do mv "${dir}" "$_pkgname" ;done
+ cd "$srcdir/$_pkgname"
+ cat <<EOT >> $pkgname
+ #!/bin/bash
+ cd /opt/$_pkgname &&
+ npm start
+EOT
+
+ chmod +x $pkgname
+ ln -sf "/opt/libelectron/node_modules" "$srcdir/$_pkgname"
+ install -dm755 "$pkgdir/opt/$_pkgname"
+ install -dm755 "$pkgdir/usr/share/pixmaps"
+ cp -r ./ "$pkgdir/opt/$_pkgname"
+ cp -r "$pkgdir/opt/$_pkgname/$pkgname.svg" "$pkgdir/usr/share/pixmaps"
+
+
+ # Link to binary
+ install -dm755 "$pkgdir/usr/bin"
+ ln -s "/opt/$_pkgname/$pkgname" "$pkgdir/usr/bin"
+
+ # Desktop Entry
+ install -Dm644 "$srcdir/$_pkgname/$_pkgname.desktop" \
+ "$pkgdir/usr/share/applications/$_pkgname.desktop"
+ sed -i s%/usr/share%/opt% "$pkgdir/usr/share/applications/$_pkgname.desktop"
+} \ No newline at end of file