summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-04-09 20:14:34 +0800
committerSukanka2022-04-09 20:14:34 +0800
commit2423433514c8abbbcdb9df79f91575261aaeb928 (patch)
tree12959390ca15d7516001ccaae01f454cf79887f0
parent615944d26f4593fc22014843640dfa50a6851c62 (diff)
downloadaur-2423433514c8abbbcdb9df79f91575261aaeb928.tar.gz
update 2.29.2
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
2 files changed, 19 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b8bdfcdadab..82f315dfd88c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stanc
pkgdesc = A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo.
- pkgver = 2.13.1
+ pkgver = 2.29.2
pkgrel = 1
url = http://mc-stan.org/
arch = i686
@@ -10,11 +10,7 @@ pkgbase = stanc
makedepends = texlive-core
makedepends = doxygen
depends = gcc-libs
- options = !libtool
- options = !strip
- options = !makeflags
- source = https://github.com/stan-dev/cmdstan/releases/download/v2.13.1/cmdstan-2.13.1.tar.gz
- sha512sums = a2b0698a28e568366876d34a052b9edb58a69e2b8d8bed9d54dcfbf786bd0219b19ad57e66982e54bc7714494d9577cad4253f832e5e3aa05af6adfc62c2ef24
+ source = https://github.com/stan-dev/cmdstan/releases/download/v2.29.2/cmdstan-2.29.2.tar.gz
+ sha512sums = 8b1485c8832fa283307b87c491f259432a7284f4975d21e5424f3b1be0ca9bf1012443c0be1b01b09aecbff40f3d1bb6031abe3bb89d8e64380f61ed9d1ffec3
pkgname = stanc
-
diff --git a/PKGBUILD b/PKGBUILD
index c0fd1cef465a..8b71943f4d55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,26 @@
-# $Id$
-# Maintainer: Ido Rosen <ido@kernel.org>
-#
-# NOTE: To request changes to this package, please submit a pull request
-# to the GitHub repository at https://github.com/ido/packages-archlinux
-# Otherwise, open a GitHub issue. Thank you! -Ido
-#
-# From the Stan website, http://mc-stan.org/ :
-# ``Stan is a package for obtaining Bayesian inference using the No-U-Turn
-# sampler, a variant of Hamiltonian Monte Carlo.'' (9/22/2013)
+# Maintainer: sukanka <su975853527 [AT] gmail.com>
+# Contributor: Ido Rosen <ido@kernel.org>
pkgname='stanc'
pkgdesc="A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo."
-pkgver=2.13.1
+pkgver=2.29.2
pkgrel=1
arch=('i686' 'x86_64')
url='http://mc-stan.org/'
license=('BSD')
depends=('gcc-libs')
-makedepends=('texlive-bin' 'texlive-core' 'doxygen')
-options=('!libtool' '!strip' '!makeflags')
-source=(https://github.com/stan-dev/cmdstan/releases/download/v$pkgver/cmdstan-$pkgver.tar.gz)
-sha512sums=('a2b0698a28e568366876d34a052b9edb58a69e2b8d8bed9d54dcfbf786bd0219b19ad57e66982e54bc7714494d9577cad4253f832e5e3aa05af6adfc62c2ef24')
+makedepends=('texlive-bin' 'texlive-core' 'doxygen'
+# needed if compile against system library
-prepare() {
- cd "${srcdir}/cmdstan-${pkgver}"
-
-}
+# 'gtest' 'benchmark' 'sundials' 'boost' 'eigen' 'tbb' 'stanmath'
+# 'python-cpplint' 'opencl-headers' 'rapidjson' 'cli11'
+)
+source=(https://github.com/stan-dev/cmdstan/releases/download/v$pkgver/cmdstan-$pkgver.tar.gz)
+sha512sums=('8b1485c8832fa283307b87c491f259432a7284f4975d21e5424f3b1be0ca9bf1012443c0be1b01b09aecbff40f3d1bb6031abe3bb89d8e64380f61ed9d1ffec3')
build() {
cd "${srcdir}/cmdstan-${pkgver}"
-
- make bin/stanc
- make bin/print
-
+ make build
}
check() {
@@ -49,24 +37,16 @@ package() {
# Install binaries:
install -dm755 "${pkgdir}/usr/bin"
install -m755 bin/stanc "${pkgdir}/usr/bin"
- install -Tm755 bin/print "${pkgdir}/usr/bin/stanc-print"
-
- # Install static library:
- install -dm755 "${pkgdir}/usr/lib"
- install -m644 bin/libstanc.a "${pkgdir}/usr/lib"
+ install -Tm755 bin/diagnose "${pkgdir}/usr/bin/standiagnose"
+ install -Tm755 bin/print "${pkgdir}/usr/bin/stanprint"
+ install -Tm755 bin/stansummary "${pkgdir}/usr/bin/stansummary"
install -dm755 "${pkgdir}/usr/include/stan"
- cd "stan_${pkgver}/src"
+ cd "stan/src"
find . -iregex './stan.*.hpp$' -type f -exec install -DTm644 "{}" "${pkgdir}/usr/include/{}" \;
cd ../..
# Install LICENSE file:
install -dm755 "${pkgdir}/usr/share/licenses/stan"
- cp -r "stan_${pkgver}/licenses/." "${pkgdir}/usr/share/licenses/stan/."
-
- # Install documentation:
- install -dm755 "${pkgdir}/usr/share/doc/stan/api"
- install -m644 doc/*.pdf \
- "${pkgdir}/usr/share/doc/stan"
- cp -r "stan_${pkgver}/doc/api/." "${pkgdir}/usr/share/doc/stan/api/."
+ cp -r "stan/licenses/." "${pkgdir}/usr/share/licenses/stan/."
}