summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-07-02 13:45:27 +0800
committersukanka2022-07-02 13:45:27 +0800
commitaeccf782f2d3ee157b068be62fd2368a8bb76757 (patch)
tree71b51767ef6102552f1937d874ef192aad47a454
parent8dc3b1c9e5bca46ef204840ed41a7ce9d05efff6 (diff)
downloadaur-aeccf782f2d3ee157b068be62fd2368a8bb76757.tar.gz
update to 2.30.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a62dcfd5dcbf..466fd53c5636 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = stanc
pkgdesc = A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo.
- pkgver = 2.29.2
- pkgrel = 2
+ pkgver = 2.30.0
+ pkgrel = 1
url = http://mc-stan.org/
arch = i686
arch = x86_64
@@ -11,7 +11,7 @@ pkgbase = stanc
makedepends = doxygen
depends = gcc-libs
provides = cmdstan
- source = https://github.com/stan-dev/cmdstan/releases/download/v2.29.2/cmdstan-2.29.2.tar.gz
- sha512sums = 8b1485c8832fa283307b87c491f259432a7284f4975d21e5424f3b1be0ca9bf1012443c0be1b01b09aecbff40f3d1bb6031abe3bb89d8e64380f61ed9d1ffec3
+ source = https://github.com/stan-dev/cmdstan/releases/download/v2.30.0/cmdstan-2.30.0.tar.gz
+ sha512sums = e304087437419bc137c2befd35b612c88075a5a660f519177098004f0546d267cceba3df363d68dc4c62392cc310dc07db01023e83e63a3f6e95c5cd6130dbbf
pkgname = stanc
diff --git a/PKGBUILD b/PKGBUILD
index 7f358509643b..3e8047250d48 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,13 +3,13 @@
pkgname='stanc'
pkgdesc="A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo."
-pkgver=2.29.2
-pkgrel=2
+pkgver=2.30.0
+pkgrel=1
arch=('i686' 'x86_64')
url='http://mc-stan.org/'
license=('BSD')
depends=('gcc-libs')
-makedepends=('texlive-bin' 'texlive-core' 'doxygen'
+makedepends=('texlive-bin' 'texlive-core' 'doxygen'
# needed if compile against system library
# 'gtest' 'benchmark' 'sundials' 'boost' 'eigen' 'tbb' 'stanmath'
@@ -17,7 +17,7 @@ makedepends=('texlive-bin' 'texlive-core' 'doxygen'
)
provides=("cmdstan")
source=(https://github.com/stan-dev/cmdstan/releases/download/v$pkgver/cmdstan-$pkgver.tar.gz)
-sha512sums=('8b1485c8832fa283307b87c491f259432a7284f4975d21e5424f3b1be0ca9bf1012443c0be1b01b09aecbff40f3d1bb6031abe3bb89d8e64380f61ed9d1ffec3')
+sha512sums=('e304087437419bc137c2befd35b612c88075a5a660f519177098004f0546d267cceba3df363d68dc4c62392cc310dc07db01023e83e63a3f6e95c5cd6130dbbf')
build() {
cd "${srcdir}/cmdstan-${pkgver}"
@@ -33,7 +33,7 @@ check() {
package() {
cd "${srcdir}/cmdstan-${pkgver}"
-
+
# Stan's makefile doesn't have a make install command...
# Install binaries:
install -dm755 "${pkgdir}/usr/bin"
@@ -46,8 +46,8 @@ package() {
install -dm755 "${pkgdir}/usr/include/stan"
cd "stan/src"
find . -iregex './stan.*.hpp$' -type f -exec install -DTm644 "{}" "${pkgdir}/usr/include/{}" \;
- cd ../..
-
+ cd ../..
+
# Install LICENSE file:
install -dm755 "${pkgdir}/usr/share/licenses/stan"
cp -r "stan/licenses/." "${pkgdir}/usr/share/licenses/stan/."