summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2022-11-09 00:03:04 +0800
committersukanka2022-11-09 00:03:04 +0800
commite962bb2686899953db4b6519c836e6e65b160f72 (patch)
treeefad2854ed6e176631928c7d01f89ae1008f310f
parentf45c96959794c9bfe4dcee3b47244eab2ff6e284 (diff)
downloadaur-e962bb2686899953db4b6519c836e6e65b160f72.tar.gz
update to 2.31.0_rc1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD17
2 files changed, 8 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 293aa2a548f3..4aea69477f86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = stanc
pkgdesc = A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo.
- pkgver = 2.30.1
+ pkgver = 2.31.0_rc1
pkgrel = 1
url = http://mc-stan.org/
arch = i686
@@ -11,7 +11,7 @@ pkgbase = stanc
makedepends = doxygen
depends = gcc-libs
provides = cmdstan
- source = https://github.com/stan-dev/cmdstan/releases/download/v2.30.1/cmdstan-2.30.1.tar.gz
- sha512sums = 5ecd8887ca4b9759581abd18d0c3f29a558d8a96a28bf78eff4167d54cd004aeed6a036b987cf8f74f0f029a8ea26cd293eaa7dfba7a152cd6ac458fdd86f371
+ source = https://github.com/stan-dev/cmdstan/releases/download/v2.31.0-rc1/cmdstan-2.31.0-rc1.tar.gz
+ sha512sums = 65f4b4d6768f7cca953c8aa4e18aa9e6ccc905d7db648e427d211f806b923f0d58f49887f38b12a21dce4ed0b9c35f4a893b60351675582f6fb85000c7933660
pkgname = stanc
diff --git a/PKGBUILD b/PKGBUILD
index 167a0054e1ba..3123097692bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname='stanc'
pkgdesc="A package for obtaining Bayesian inference using the No-U-Turn sampler, a variant of Hamiltonian Monte Carlo."
-pkgver=2.30.1
+pkgver=2.31.0_rc1
pkgrel=1
arch=('i686' 'x86_64')
url='http://mc-stan.org/'
@@ -16,23 +16,16 @@ makedepends=('texlive-bin' 'texlive-core' 'doxygen'
# 'python-cpplint' 'opencl-headers' 'rapidjson' 'cli11'
)
provides=("cmdstan")
-source=(https://github.com/stan-dev/cmdstan/releases/download/v$pkgver/cmdstan-$pkgver.tar.gz)
-sha512sums=('5ecd8887ca4b9759581abd18d0c3f29a558d8a96a28bf78eff4167d54cd004aeed6a036b987cf8f74f0f029a8ea26cd293eaa7dfba7a152cd6ac458fdd86f371')
+source=(https://github.com/stan-dev/cmdstan/releases/download/v${pkgver/_/-}/cmdstan-${pkgver/_/-}.tar.gz)
+sha512sums=('65f4b4d6768f7cca953c8aa4e18aa9e6ccc905d7db648e427d211f806b923f0d58f49887f38b12a21dce4ed0b9c35f4a893b60351675582f6fb85000c7933660')
build() {
- cd "${srcdir}/cmdstan-${pkgver}"
+ cd "${srcdir}/cmdstan-${pkgver/_/-}"
make build
}
-check() {
- cd "${srcdir}/cmdstan-${pkgver}"
-
- # There are tests for the CmdStan interface
- # make src/test/interface
-}
-
package() {
- cd "${srcdir}/cmdstan-${pkgver}"
+ cd "${srcdir}/cmdstan-${pkgver/_/-}"
# Stan's makefile doesn't have a make install command...
# Install binaries: