summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartins Mozeiko2020-08-29 16:10:57 -0700
committerMartins Mozeiko2020-08-29 16:10:57 -0700
commit4ae2b8669ebef524a9537241dc7ee247874fb5f5 (patch)
tree7259a5d4202c476fb95e8b6fde43711148a8686c
downloadaur-4ae2b8669ebef524a9537241dc7ee247874fb5f5.tar.gz
initial commit, v0.5.0
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD39
-rw-r--r--standardfile.service16
-rw-r--r--standardfile.sysusers1
-rw-r--r--standardfile.tmpfiles1
-rw-r--r--standardfile.yaml6
7 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6592e67f052
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = standardfile-bin
+ pkgdesc = Standard File Server, Go Implementation
+ pkgver = 0.5.0
+ pkgrel = 1
+ url = https://github.com/tectiv3/standardfile
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ depends = glibc
+ backup = etc/standardfile.yaml
+ source = standardfile.service
+ source = standardfile.sysusers
+ source = standardfile.tmpfiles
+ source = standardfile.yaml
+ sha256sums = 0162b6f97c6fda82a2b86e1b544ae10cb0d17e7561a3b3930d782dfef5a89d74
+ sha256sums = a5e8669b915dc6553f0af9137840adfabb020f391846d9f3ab3dbe3175d320fa
+ sha256sums = 2014138283a50581136b85a4d4964ee70821cb0ed965fa5acc1c3d7611855288
+ sha256sums = 46c37eca9600032a36c510fed63838e003f46b967b19538ff7cbc26a74849a54
+ source_i686 = https://github.com/tectiv3/standardfile/releases/download/v0.5.0/standardfile_0.5.0_linux_32-bit.tar.gz
+ sha256sums_i686 = a87fe60aa2a172526c5aae46a6a099b7bde40f67f3b43f408fdd2410669a2aa0
+ source_x86_64 = https://github.com/tectiv3/standardfile/releases/download/v0.5.0/standardfile_0.5.0_linux_64-bit.tar.gz
+ sha256sums_x86_64 = c8120132c7d148e28f8e4a4670d30fb715e256611bf97903991cbc20f7742fd7
+ source_armv6h = https://github.com/tectiv3/standardfile/releases/download/v0.5.0/standardfile_0.5.0_linux_arm6.tar.gz
+ sha256sums_armv6h = 24b91436a6dd4d53186edfaaed8d33c6ac4d19a83555044ba4fcebd44a8ada25
+ source_armv7h = https://github.com/tectiv3/standardfile/releases/download/v0.5.0/standardfile_0.5.0_linux_arm7.tar.gz
+ sha256sums_armv7h = 458bbf2fe58af523e9d816cf8727b324ad66f246ad51fedabf18e31558cec751
+ source_aarch64 = https://github.com/tectiv3/standardfile/releases/download/v0.5.0/standardfile_0.5.0_linux_arm8.tar.gz
+ sha256sums_aarch64 = 2ca2e7f883387c127fc1fc4de3372639a199ae502f37d7340546455a81af65c9
+
+pkgname = standardfile-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4e1c38b577ba
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+pkg
+src
+*.tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fff3ca418294
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Martins Mozeikox <martins.mozeiko@gmail.com>
+
+pkgname=standardfile-bin
+pkgver=0.5.0
+pkgrel=1
+pkgdesc='Standard File Server, Go Implementation'
+url='https://github.com/tectiv3/standardfile'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+license=('MIT')
+depends=('glibc')
+backup=('etc/standardfile.yaml')
+source_i686=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_32-bit.tar.gz")
+source_x86_64=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_64-bit.tar.gz")
+source_arm=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_arm6.tar.gz")
+source_armv6h=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_arm6.tar.gz")
+source_armv7h=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_arm7.tar.gz")
+source_aarch64=("https://github.com/tectiv3/standardfile/releases/download/v${pkgver}/standardfile_${pkgver}_linux_arm8.tar.gz")
+sha256sums_i686=('a87fe60aa2a172526c5aae46a6a099b7bde40f67f3b43f408fdd2410669a2aa0')
+sha256sums_x86_64=('c8120132c7d148e28f8e4a4670d30fb715e256611bf97903991cbc20f7742fd7')
+sha256sums_arm=('24b91436a6dd4d53186edfaaed8d33c6ac4d19a83555044ba4fcebd44a8ada25')
+sha256sums_armv6h=('24b91436a6dd4d53186edfaaed8d33c6ac4d19a83555044ba4fcebd44a8ada25')
+sha256sums_armv7h=('458bbf2fe58af523e9d816cf8727b324ad66f246ad51fedabf18e31558cec751')
+sha256sums_aarch64=('2ca2e7f883387c127fc1fc4de3372639a199ae502f37d7340546455a81af65c9')
+source=(standardfile.service
+ standardfile.sysusers
+ standardfile.tmpfiles
+ standardfile.yaml)
+sha256sums=('0162b6f97c6fda82a2b86e1b544ae10cb0d17e7561a3b3930d782dfef5a89d74'
+ 'a5e8669b915dc6553f0af9137840adfabb020f391846d9f3ab3dbe3175d320fa'
+ '2014138283a50581136b85a4d4964ee70821cb0ed965fa5acc1c3d7611855288'
+ '46c37eca9600032a36c510fed63838e003f46b967b19538ff7cbc26a74849a54')
+
+package() {
+ install -Dm 755 "${srcdir}/standardfile" "${pkgdir}/usr/bin/standardfile"
+ install -Dm 644 "${srcdir}/standardfile.service" "${pkgdir}/usr/lib/systemd/system/standardfile.service"
+ install -Dm 644 "${srcdir}/standardfile.sysusers" "${pkgdir}/usr/lib/sysusers.d/standardfile.conf"
+ install -Dm 644 "${srcdir}/standardfile.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/standarfile.conf"
+ install -Dm 644 "${srcdir}/standardfile.yaml" "${pkgdir}/etc/standardfile.yaml"
+}
diff --git a/standardfile.service b/standardfile.service
new file mode 100644
index 000000000000..1adf2764a42a
--- /dev/null
+++ b/standardfile.service
@@ -0,0 +1,16 @@
+[Unit]
+Description=Standard File Server daemon
+After=network.target
+Wants=network.target
+
+[Service]
+User=standardfile
+Group=standardfile
+Type=forking
+WorkingDirectory=/var/lib/standardfile
+ExecStart=/usr/bin/standardfile -c /etc/standardfile.yaml
+PIDFile=/var/lib/standardfile/pid
+Restart=on-abnormal
+
+[Install]
+WantedBy=multi-user.target
diff --git a/standardfile.sysusers b/standardfile.sysusers
new file mode 100644
index 000000000000..0a166271cd8f
--- /dev/null
+++ b/standardfile.sysusers
@@ -0,0 +1 @@
+u standardfile - "standardfile daemon" /var/lib/standarfile \ No newline at end of file
diff --git a/standardfile.tmpfiles b/standardfile.tmpfiles
new file mode 100644
index 000000000000..2f2d13a5f87f
--- /dev/null
+++ b/standardfile.tmpfiles
@@ -0,0 +1 @@
+d /var/lib/standardfile 0750 standardfile standardfile
diff --git a/standardfile.yaml b/standardfile.yaml
new file mode 100644
index 000000000000..3d98c68d2157
--- /dev/null
+++ b/standardfile.yaml
@@ -0,0 +1,6 @@
+port: 8888
+foreground: false
+debug: false
+noreg: true
+cors: true
+db: /var/lib/standardfile/standardfile.db