summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Price2017-11-07 12:19:30 +0000
committerWill Price2017-11-07 12:19:30 +0000
commitfa0433d6a8422f8dfa4be12825309bdbff0c1744 (patch)
treeff3dfeb90e5f428b276eabf679fe1eca471b7f1f
downloadaur-fa0433d6a8422f8dfa4be12825309bdbff0c1744.tar.gz
Initial commit: 3.8.0
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD37
3 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f03880a86f2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Nov 7 12:19:20 UTC 2017
+pkgbase = stanford-parser
+ pkgdesc = A natural language parser is a program that works out the grammatical structure of sentences.
+ pkgver = 3.8.0
+ pkgrel = 1
+ url = https://nlp.stanford.edu/software/lex-parser.shtml#Download
+ arch = x86_64
+ license = GPL
+ depends = java-runtime
+ optdepends = stanford-parser-en-models: English models
+ provides = stanford-parser
+ source = https://nlp.stanford.edu/software/stanford-parser-full-2017-06-09.zip
+ md5sums = 93695f5f6d42ac17f140965d239d1bc1
+
+pkgname = stanford-parser
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..488c3f3e6d1f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.pkg*
+*.zip
+*.tar
+src
+pkg
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..24a685c33c6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Will Price <will.price94@gmail.com>
+pkgname=stanford-parser
+pkgver=3.8.0
+pkgrel=1
+pkgdesc="A natural language parser is a program that works out the grammatical structure of sentences."
+arch=(x86_64)
+url="https://nlp.stanford.edu/software/lex-parser.shtml#Download"
+license=('GPL')
+groups=()
+depends=(java-runtime)
+optdepends=('stanford-parser-en-models: English models')
+provides=('stanford-parser')
+_version=2017-06-09
+source=("https://nlp.stanford.edu/software/stanford-parser-full-${_version}.zip")
+md5sums=('93695f5f6d42ac17f140965d239d1bc1')
+
+package() {
+ cd "${srcdir}/stanford-parser-full-${_version}"
+ mkdir -p "${pkgdir}"/usr/{bin,share/{stanford-parser,doc/stanford-parser}}
+ cp -r . "${pkgdir}/usr/share/stanford-parser"
+
+ pushd "${pkgdir}/usr/bin"
+ for script in lexparser{,-{gui,lang,lang-train-test}}; do
+ cat > ${pkgdir}/usr/bin/${script} <<- EOF
+ #!/bin/bash
+
+ cd /usr/share/stanford-parser
+ ./${script}.sh
+ EOF
+ chmod +x ${pkgdir}/usr/bin/${script}
+ done
+ popd
+
+ for doc in README{,_dependencies}.txt; do
+ install -m 644 ${doc} ${pkgdir}/usr/share/doc/stanford-parser/
+ done
+}