summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Aslanyan2022-05-26 20:37:44 +0600
committerArthur Aslanyan2022-05-26 20:37:44 +0600
commit509a097ff7e6271e0e61d363c27391b07589f19f (patch)
treec0fd626a787dbda9df4023df2ceea441eea780cb
parentc0e83ce6b5e49df3bbf4d2a2b3ad00b4f58f5225 (diff)
downloadaur-509a097ff7e6271e0e61d363c27391b07589f19f.tar.gz
Update license info
- [ADDED] custom license as project uses several licenses (GPL3 for core and commercial license for plugins) - [ADDED] .gitignore for cleaner workflow and testing
-rw-r--r--.SRCINFO1
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD7
3 files changed, 11 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f3df6a199646..2efe6dce16d9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,6 +5,7 @@ pkgbase = starc-appimage
url = https://starc.app/
arch = x86_64
license = GPL3
+ license = custom
depends = zlib
depends = bash
provides = starc=0.1.5
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..2497a2c0f0e2
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+src/
+pkg/
+*.pkg.tar.zst
+*.AppImage
diff --git a/PKGBUILD b/PKGBUILD
index 6ecf45ba09a3..0166bee5e3c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgrel=1
pkgdesc="Story Architect is a text editor for film, theatre, radio scripts or comic books."
arch=('x86_64')
url='https://starc.app/'
-license=('GPL3')
+license=('GPL3' 'custom')
depends=('zlib' 'bash')
provides=("${_name}=${pkgver}")
conflicts=("${_name}")
@@ -28,9 +28,14 @@ prepare() {
}
package() {
+ # Install AppImage and bin
install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/opt/appimages/${_name}.AppImage"
install -Dm755 "${srcdir}/${_name}.sh" "${pkgdir}/usr/bin/${_name}"
+ # Install icon and desktop
install -Dm644 "${srcdir}/squashfs-root/${_name}.png" "${pkgdir}/usr/share/pixmaps/${_name}.png"
install -Dm644 "${srcdir}/squashfs-root/${_name}.desktop" "${pkgdir}/usr/share/applications/${_name}.desktop"
+
+ # TODO: Install custom LICENSE when author makes it
+ # install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}