summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorArthur Aslanyan2022-05-25 20:41:14 +0600
committerArthur Aslanyan2022-05-25 20:41:14 +0600
commitc0e83ce6b5e49df3bbf4d2a2b3ad00b4f58f5225 (patch)
tree0f8628de62e6d571468479ec1a8140fb6da3d25c
downloadaur-c0e83ce6b5e49df3bbf4d2a2b3ad00b4f58f5225.tar.gz
First commit
- [ADDED] Project files
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
-rw-r--r--starc.desktop.patch11
-rw-r--r--starc.sh2
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3df6a199646
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = starc-appimage
+ pkgdesc = Story Architect is a text editor for film, theatre, radio scripts or comic books.
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://starc.app/
+ arch = x86_64
+ license = GPL3
+ depends = zlib
+ depends = bash
+ provides = starc=0.1.5
+ conflicts = starc
+ options = !strip
+ source = https://github.com/story-apps/starc/releases/download/v0.1.5/starc-setup.AppImage
+ source = starc.desktop.patch
+ source = starc.sh
+ sha256sums = fb98d6c8a84e0873d264c615b639341a1edf1a72fb61d960e0af9ecc15a7f63a
+ sha256sums = 583fcc57942d9c9e1a8e41a0a95fcc3f4cdd1660767e014921c30a3fa272f5fa
+ sha256sums = 642005557de950e4fd37bc87fe2fb051e7f93f61e7287161fe3c99c9918977c7
+
+pkgname = starc-appimage
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ecf45ba09a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Arthur Aslanyan <arthur.e.aslanyan@gmail.com>
+_name=starc
+_filename='starc-setup.AppImage'
+
+pkgname="${_name}-appimage"
+pkgver=0.1.5
+pkgrel=1
+pkgdesc="Story Architect is a text editor for film, theatre, radio scripts or comic books."
+arch=('x86_64')
+url='https://starc.app/'
+license=('GPL3')
+depends=('zlib' 'bash')
+provides=("${_name}=${pkgver}")
+conflicts=("${_name}")
+options=(!strip)
+source=("https://github.com/story-apps/starc/releases/download/v${pkgver}/${_filename}"
+ "${_name}.desktop.patch"
+ "${_name}.sh")
+sha256sums=('fb98d6c8a84e0873d264c615b639341a1edf1a72fb61d960e0af9ecc15a7f63a'
+ '583fcc57942d9c9e1a8e41a0a95fcc3f4cdd1660767e014921c30a3fa272f5fa'
+ '642005557de950e4fd37bc87fe2fb051e7f93f61e7287161fe3c99c9918977c7')
+
+prepare() {
+ cd "${srcdir}"
+ chmod +x $_filename
+ ./$_filename --appimage-extract
+ patch -Np0 < "./${_name}.desktop.patch"
+}
+
+package() {
+ install -Dm755 "${srcdir}/${_filename}" "${pkgdir}/opt/appimages/${_name}.AppImage"
+ install -Dm755 "${srcdir}/${_name}.sh" "${pkgdir}/usr/bin/${_name}"
+
+ install -Dm644 "${srcdir}/squashfs-root/${_name}.png" "${pkgdir}/usr/share/pixmaps/${_name}.png"
+ install -Dm644 "${srcdir}/squashfs-root/${_name}.desktop" "${pkgdir}/usr/share/applications/${_name}.desktop"
+}
diff --git a/starc.desktop.patch b/starc.desktop.patch
new file mode 100644
index 000000000000..44a272fe4bde
--- /dev/null
+++ b/starc.desktop.patch
@@ -0,0 +1,11 @@
+--- squashfs-root/starc.desktop
++++ squashfs-root/starc.desktop
+@@ -4,7 +4,7 @@
+ Type=Application
+ Icon=starc
+ Categories=Office;
+-Exec=starc %f
++Exec=/usr/bin/starc %f
+ MimeType=application/x-starc-project;
+ Name=Story Architect
+ GenericName=Storywriting software
diff --git a/starc.sh b/starc.sh
new file mode 100644
index 000000000000..b232b5cd6d58
--- /dev/null
+++ b/starc.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+/opt/appimages/starc.AppImage "$@"