summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRaffaele Mancuso2023-10-29 12:05:17 +0100
committerRaffaele Mancuso2023-10-29 12:05:17 +0100
commit3daa5ebd4f3ea261295cb82d873f4dae4188dac1 (patch)
treea344a4800ac4e5e87e207aae11f43671397ac097
downloadaur-3daa5ebd4f3ea261295cb82d873f4dae4188dac1.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD34
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2117d1c3f01c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stardict-bobotig-fr
+ pkgdesc = French monolingual dictionary, based on Wiktionary, StarDict file format, BoboTiG's daily dumps
+ pkgver = 2023_10_20
+ pkgrel = 1
+ url = https://github.com/BoboTiG/ebook-reader-dict
+ arch = any
+ license = cc-by-sa-3.0
+ source = https://github.com/BoboTiG/ebook-reader-dict/releases/download/fr/dict-fr-fr.zip
+ source = https://github.com/BoboTiG/ebook-reader-dict/releases/download/fr/dict-fr-fr.zip.sha256
+ b2sums = SKIP
+ b2sums = SKIP
+
+pkgname = stardict-bobotig-fr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..155c8344b0fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Raffaele Mancuso <raffaelemancuso532@gmail.com>
+_lang=fr
+_langfull=French
+pkgname="stardict-bobotig-${_lang}"
+pkgver=2023_10_20
+pkgrel=1
+pkgdesc="${_langfull} monolingual dictionary, based on Wiktionary, StarDict file format, BoboTiG's daily dumps"
+arch=("any")
+url="https://github.com/BoboTiG/ebook-reader-dict"
+license=('cc-by-sa-3.0')
+source=("https://github.com/BoboTiG/ebook-reader-dict/releases/download/${_lang}/dict-${_lang}-${_lang}.zip"{,.sha256})
+b2sums=("SKIP"
+ "SKIP")
+
+pkgver() {
+ sed -n 's/^date=//p' dict-data.ifo | sed 's/-/_/g'
+}
+
+package() {
+ sha256sum --strict --check "dict-${_lang}-${_lang}.zip.sha256"
+ if [ "$?" -ne 0 ]; then
+ echo "Checksum is wrong. Aborting"
+ exit
+ else
+ echo "Checksum OK"
+ fi
+ install -Dm644 dict-data.dict.dz dict-data.idx dict-data.ifo -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}"
+ if [ -f dict-data.syn ]; then
+ install -Dm644 dict-data.syn -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}"
+ fi
+ if [ -d ./res ]; then
+ install -Dm644 ./res/* -t "${pkgdir}/usr/share/stardict/dic/bobotig-${_lang}/res"
+ fi
+}