aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorvvasuki2020-03-01 14:14:19 +0530
committervvasuki2020-03-01 14:14:19 +0530
commit194e12d0c8f7b7feac964b065c53ccd1deff9e30 (patch)
treea33cd717fcfa520c967529725d66fb87d6503883
downloadaur-194e12d0c8f7b7feac964b065c53ccd1deff9e30.tar.gz
CU
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore10
-rw-r--r--PKGBUILD24
-rw-r--r--README.md25
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8037bef338b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,10 @@
+pkgbase = stardict-indic-update
+ pkgdesc = Stardict dictionaries (see url for details): Sanskrit, Pali, Malayalam, Kannada, Tamil, Telugu, Bengali, Oriya, Hindi, Nepali, Gujarati, Marathi, Punjabi, Sinhala, Assamese, English, Latin...
+ pkgver = 1.0
+ pkgrel = 1
+ url = http://github.com/indic-dict/stardict-indic-update-aur
+ arch = any
+ depends = goldendict
+
+pkgname = stardict-indic-update
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..65c36083f8a6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,10 @@
+*.iml
+
+# Arch linux packaging.
+releases
+pkg
+src
+aur
+*.tar.gz
+*.tar.xz
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0cfa64cdf595
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Maintainer: Sanskrit Coders <sanskrit-programmers@googlegroups.com>
+pkgname=stardict-indic-update
+pkgver=1.0
+pkgrel=1
+pkgdesc="Stardict dictionaries (see url for details): Sanskrit, Pali, Malayalam, Kannada, Tamil, Telugu, Bengali, Oriya, Hindi, Nepali, Gujarati, Marathi, Punjabi, Sinhala, Assamese, English, Latin..."
+url="http://github.com/indic-dict/stardict-indic-update-aur"
+# license=('custom:OFL')
+arch=(any)
+
+# source=("")
+# sha256sums=('')
+
+build() {
+ wget -N https://github.com/sanskrit-coders/dict-tools/raw/master/bin/artifacts/dict-tools.jar
+}
+
+package() {
+ install -d "$pkgdir/usr/share/dictionaries/"
+ java -jar "$srcdir/dict-tools.jar" install --destinationPath "$pkgdir/usr/share/dictionaries" --dictRepoIndexUrl https://raw.githubusercontent.com/sanskrit-coders/stardict-dictionary-updater/master/dictionaryIndices.md --overwrite true
+}
+
+depends=(
+'goldendict'
+) \ No newline at end of file
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..a025c643a738
--- /dev/null
+++ b/README.md
@@ -0,0 +1,25 @@
+## Intro
+Installs stardict dictionaries from the https://github.com/indic-dict/ project. Languages covered: Sanskrit, Pali, Malayalam, Kannada, Tamil, Telugu, Bengali, Oriya, Hindi, Nepali, Gujarati, Marathi, Panjabi/ Punjabi, Sinhala, Assamese, English, Latin...
+
+## Technical info
+- AUR package location: <https://aur.archlinux.org/packages/stardict-indic-update/>
+- Package source code locations:
+ - git clone git@github.com:sanskrit-coders/stardict-indic-update-aur.git
+ - git clone ssh://aur@aur.archlinux.org/stardict-indic-update.git
+
+## Creating a new Arch Linux package release
+- Create a github release at <https://github.com/indic-dict/dict-tools/releases>.
+- Update PKGBUILD.
+ - Fix the version numbers.
+ - Get the sha256sum by:
+ - Downloading the github release package.
+ - running something like `sha256sum sanskrit-fonts-1.0.tar.gz`
+- Verify package by running `makepkg -si`.
+- Update AUR repository.
+ - Set remote: `git remote add ssh://aur@aur.archlinux.org/stardict-indic-update.git .`
+ - Generate or update .SRCINFO with `makepkg --printsrcinfo > .SRCINFO`
+ - Push to the AUR repo. (Even a single invalid commit will cause rejection.)
+
+## References
+- https://wiki.archlinux.org/index.php/creating_packages
+