summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThesourtimes2022-06-04 17:36:10 +0300
committerThesourtimes2022-06-04 17:36:10 +0300
commit36a9be1b9648f98167fbc817fec11b3e2d75c63e (patch)
tree344e279c91d06d985d0e9d75a46b05a9134ce6e5
downloadaur-36a9be1b9648f98167fbc817fec11b3e2d75c63e.tar.gz
init
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8af9d408c64
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = stardict-tr-2011
+ pkgdesc = Turkish Language Association's Turkish dictionary (2011) for Stardict
+ pkgver = 2.4.2
+ pkgrel = 1
+ url = https://github.com/kunamech/stardict-con/
+ arch = any
+ license = custom:public domain
+ optdepends = stardict: view the dictionary
+ optdepends = sdcv: view the dictionary in CLI
+ source = https://github.com/kunamech/stardict-con/raw/master/dist/guncel-turkce-sozluk_turk-dil-kurumu-2011/stardict-guncel-turkce-sozluk_turk-dil-kurumu-2011.tar.gz
+ md5sums = 1647f6ddf7a42b16253f2bb2fba4bb7d
+
+pkgname = stardict-tr-2011
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd95e5ba83c8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Kuna <kunamech@protonmail.ch>
+
+pkgname=stardict-tr-2011
+pkgver=2.4.2
+pkgrel=1
+pkgdesc="Turkish Language Association's Turkish dictionary (2011) for Stardict"
+arch=('any')
+license=('custom:public domain')
+optdepends=('stardict: view the dictionary'
+ 'sdcv: view the dictionary in CLI')
+url="https://github.com/kunamech/stardict-con/"
+md5sums=('1647f6ddf7a42b16253f2bb2fba4bb7d')
+
+source=('https://github.com/kunamech/stardict-con/raw/master/dist/guncel-turkce-sozluk_turk-dil-kurumu-2011/stardict-guncel-turkce-sozluk_turk-dil-kurumu-2011.tar.gz')
+
+package() {
+ mkdir -vp "$pkgdir/usr/share/stardict/dic/tdk-2011" "$pkgdir/usr/share/licenses/stardict-tr-2011";
+ cp -vf "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/stardict-tr-2011";
+ cd "$srcdir/dic/Güncel Türkçe Sözlük - Türk Dil Kurumu 2011";
+ install -m 644 *.dict *.idx *.ifo "$pkgdir/usr/share/stardict/dic/tdk-2011";
+}
+
+# vim:set ts=2 sw=2 et: