summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlxgr-linux2022-03-28 19:23:20 +0200
committerlxgr-linux2022-03-28 19:23:20 +0200
commit6668cf86cf59db8ef569b2f15fa12214c85a0500 (patch)
tree7c03919ef26b016f3caf49006f4dfa7f527b0c87
downloadaur-6668cf86cf59db8ef569b2f15fa12214c85a0500.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d067484f5aac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = starport-git
+ pkgdesc = The all-in-one platform to build, launch and maintain any crypto application on a sovereign and secured blockchain
+ pkgver = nightly
+ pkgrel = 1
+ url = https://starport.com
+ arch = any
+ license = Apache
+ makedepends = git
+ makedepends = go
+ provides = starport
+ conflicts = starport-bin
+ source = starport-git::git+https://github.com/tendermint/starport
+ md5sums = SKIP
+
+pkgname = starport-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0319e82d0a8a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: lxgr <lxgr@protonmail.com>
+
+pkgbase='starport-git'
+pkgname='starport-git'
+pkgver=nightly
+pkgrel=1
+pkgdesc="The all-in-one platform to build, launch and maintain any crypto application on a sovereign and secured blockchain"
+arch=(any)
+url="https://starport.com"
+license=('Apache')
+provides=('starport')
+depends=()
+makedepends=('git' 'go')
+conflicts=('starport-bin')
+source=("$pkgbase"::'git+https://github.com/tendermint/starport')
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgbase"
+ git describe --tags --always | sed -r 's|release-||g;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgbase"
+ make build
+}
+
+package() {
+ cd "$srcdir/$pkgbase"
+ install -Dm0755 -t "$pkgdir/usr/bin/" ./dist/*
+}